0
$\begingroup$

I set up my HDRI light image as a viewport shading. Unchecked the scene lights and scene world. I fiddled a lot with rotation to get the reflections I wanted. When I render it i have no lights at all. I understand that's because viewport shading is separate but how I can setup my render to look the same?

When I add the same image as world>background>environment texture:

First I don't have any easy way to control rotation.

Second the background lights are visible on the render - I want single color/transparent background.

$\endgroup$
2
$\begingroup$

enter image description here

Turn transparent ON in Film in Rendering Settings.

Go to Shader editor, choose World, add environnement node (open your HDRI here), mapping node, and texture coordinate and set it up like so. in mapping node you can change HDRI orientation by changing Z rotation value.

That should answer all your questions.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.