0
$\begingroup$

Very simple question, but I cannot find a solution.

I added a Cone primitive to my scene, but I need it to be smoothly shaded so it looks perfectly round. My first instinct is to turn on smooth shading, like a lot of other people. I did this, but the bottom of the cone didn't look right so I turned on auto smooth.

The big problem is with the top vertex because now, no matter what I do, the smooth shading treats the cone as if it were flat producing a very unreal result. How can I smooth shade this cone? It would be best if the original geometry of the cone is minimally changed.

Other things I have tried:

  • Adjusting the smooth shading angle limit
  • Subdivision Surface
  • Making a Cylinder, but scaling the top to 0
  • Making a Cylinder, but scaling the top to a small number, like 0.1
  • Remesh Modifier

enter image description here

$\endgroup$
2
  • $\begingroup$ How many vertices does your cone have? $\endgroup$
    – moonboots
    Sep 14 '20 at 14:44
  • $\begingroup$ @moonboots does that matter? $\endgroup$
    – Eric Xue
    Sep 14 '20 at 14:53
3
$\begingroup$

I think I found a solution.

  1. Add a cylinder
  2. Scale top to 0
  3. Add some edge loops (I used the cylinder because you can't add edge loops on a cone)
  4. Merge the vertices by distance so you have only one top vertex
  5. Edge slide the uppermost loop as close to the tip of the cone as possible
  6. Turn on smooth shading
  7. Turn on auto smooth
  8. Select the bottom face of the cone and Edge Crease it to 1
  9. Add a subdivision surface modifier

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.