0
$\begingroup$

I want to render a image in 20000x20000 pixels. But I get the error GPU out of memory. My Peak in constantly getting higher. It starts at 280M, after a hour it is 2000M.

I have a GeForce GTX 1060 6GB. I uploaded my model via an OBJ file it. The Blend file is 90 mB. I have save buffers on to reduce the memory usage .

Has someone a idea how i can still render this image in 20000x20000 pixels? or is this just not possible.

Thank you in advance.

$\endgroup$
  • 2
    $\begingroup$ can you try switching to CPU rendering and have you got enough RAM / Swap space to handle it? Also have you tried rending at 10%, 25%,50% to find a sweet spot. You maybe able to resize the image in an image editor and get reasonable results. $\endgroup$ – rob Jun 4 at 13:16
  • $\begingroup$ What you don't say in your post is the contents of the scene: number of vertices\faces\triangles, modifiers, size of textures, etc. nor do you mention the size of tiles, number of samples or ram available in your system. Give some more info so that someone can help you. $\endgroup$ – cegaton Jun 4 at 15:00
  • $\begingroup$ This is probably besides the point, but the size suggests you are creating print data? You would only need this size to print 338cm@150ppi wide. On bigger Banners, the ppi can even go lower. letsenhance.io can be a help to achieve this in one go with your 1060 rig, it created very usable data for a blow up of a high res image. I printed 6000mm*5200mm on silk @200ppi without artifacts from a 5700px source (enhance to 47244px*40945px). At the end mixing in some high res noise. Try if it works for you. If you want to get those "real" pixels you will need some real hardware. $\endgroup$ – BK. Jun 4 at 16:45
  • $\begingroup$ Related: How to render a 30K image with cycles? $\endgroup$ – brockmann Jun 4 at 17:56
2
$\begingroup$

Use the "Precise Render Border Adjust" addon.

enter image description here

It allows you to easily split the render into smaller tiles which you can combine later in an image editor.

enter image description here

When rendering just make sure that cropping is enabled, otherwise blender will try to construct the complete image, which may freeze or crash the program upon completion or while exporting.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.