I created a scene and after some test renders at 50% resolution, I want to render the full resolution (which is 1920x800). However, blender always crashes after a few minutes, often even before it starts sampling.

My system specs are:

CPU: Intel i7-6500U

GPU: Nvidia GeForce GTX 950M (2GB VRAM)


which is a pretty low-end setup considering the complexity of my scene (about 700 million vertices), but why does blender crash? The test renders worked fine; they took around half an hour to render. What is different when rendering at higher resolutions? Shouldn't blender just take 4 times as long to render it?

I would attatch my .blend file, but it's too large (600MB)

  • 1
    $\begingroup$ A few choices: Render in parts that your computer can deal with and composite later. Or simplify your scene. Or use a render farm. Or render using CPU. Do you really need 700 million vertices? 3D is all about faking and optimizing, try to use detail only where it shows. $\endgroup$
    – susu
    Jun 19, 2020 at 16:17
  • $\begingroup$ @susu thanks for your tips. Unfortunately, render layers is not possible with my scene because there is lots of fog. I already tried to reduce the vertice count as much as possible, but I created a big landscape with 130.000 (low-poly) trees. Render farms might be something to look into. Anyway, thanks! $\endgroup$
    – jng224
    Jun 19, 2020 at 16:23
  • $\begingroup$ as @susu said use render layers. using render layers with fog is always possible, have done so successfully myself because was only way to render in reasonable time. also, 2GB VRAM is not alot, and blender will use that up quickly. Simplify things, remove what the camera wont see and use small textures. $\endgroup$
    – Timaroberts
    Jun 19, 2020 at 17:56

1 Answer 1


This answer probybly depends on the scene, but I found that reducing the tasks Blender has to do helps: For me, this was turning off motion blur (which I will later add in a video editing software). Other approaches could be reducing light bounces or samples.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .