My GTX 960 is reporting there there is not enough memory, even when another person the same card is able to render it fine. The other person had the same set up as I do and rendered the same scenes. He did not have this issue.

I'm a render farmer for black plasma studios and I have come across this problem with my rendering recently. I was doing a benchmark test for them and blender gave the error (in the title).

My first test went good: Simple_Render

But I got the error on my second test: Heavy_Render

as you can see it renders the first square but then runs out of memory after that. It did not render at all until I updated my graphics drivers with GeForce Experience. This helped a little but the render still didn't finish.

I seem to get this error a lot now and I would assume a better graphics card would be needed but someone else in the group has the same one that I have and he can do it just fine.

Computer info:

Display Device:
name: NVIDIA GeForce GTX 960
DAC type: Integrated RAMDAC
Device Type: Full Display Device
Approx Memory: 6091 MB

System:
OS: Windows 10 Home 64-bit
processor: Intel Core i5-6600K CPU @ 3.50GHz (4 CPUs), about 3.5GHz
Current Display Mode: 1920 x 1080 (32 bit) (60Hz)
Memory: 8148MB RAM

How do I fix this?

  • The first testscene that went good has much lesser memory consumtion than the more complex scene in the second test. I guess your GTX 960 has about 2048 MB dedicated Memory... so i think you run out of GPU Memory with that scene. Did the other guy with the Card render the same scene? – Stillnotstatic Aug 25 '16 at 21:23
  • 1
    Also, note that many cards come in dozens of variations, so they may have had a 4, 6, or even 8GB version – VRM Aug 25 '16 at 22:22
  • yea he rendered same scene – willycraigbryant Aug 25 '16 at 23:38
  • The fact that someone else with the same card can render doesn't mean much, unless your computers are configured exactly the same way. In any case when you run out of memory it means only one thing: your scene exceeds the resources available to render it. Your options are 1-Simplify the scene, 2- Render using the terminal. 3 render using CPU. In any of those cases is always wise to close all other apps and not use the computer while it is rendering. – cegaton Mar 29 '17 at 14:11

There are two options.

First:

Your scene render is bigger then your GTX 960 memory.

Solution:

Change render to CPU.

Second:

You have active 'render preview mode' and 'final render' at once.

Solution:

Turn off 'preview mode' or change it to 'solid/wireframe'.

  • Didn't seem to work. why did the other GTX 960 didn't run out of memory or have to change any blender settings but mine I seem to have to do so? – willycraigbryant Aug 25 '16 at 23:44
  • Maybe you have another software using it hardly in the background? Minimized game or something? – cgslav Aug 25 '16 at 23:45
  • Tried it, I lowered the title size to 128x128 and got lot furthure still ran out eventully – willycraigbryant Aug 26 '16 at 1:07
  • Could you post in edit screenshot from Windows Task Manager while render is on? Detailed view, Performance tab and Processes. – cgslav Aug 26 '16 at 1:22

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.