My GTX 960 is reporting there there is not enough memory, even when another person the same card is able to render it fine. The other person had the same set up as I do and rendered the same scenes. He did not have this issue.

I'm a render farmer for black plasma studios and I have come across this problem with my rendering recently. I was doing a benchmark test for them and blender gave the error (in the title).

My first test went good: Simple_Render

But I got the error on my second test: Heavy_Render

as you can see it renders the first square but then runs out of memory after that. It did not render at all until I updated my graphics drivers with GeForce Experience. This helped a little but the render still didn't finish.

I seem to get this error a lot now and I would assume a better graphics card would be needed but someone else in the group has the same one that I have and he can do it just fine.

Computer info:

Display Device:
name: NVIDIA GeForce GTX 960
DAC type: Integrated RAMDAC
Device Type: Full Display Device
Approx Memory: 6091 MB

OS: Windows 10 Home 64-bit
processor: Intel Core i5-6600K CPU @ 3.50GHz (4 CPUs), about 3.5GHz
Current Display Mode: 1920 x 1080 (32 bit) (60Hz)
Memory: 8148MB RAM

How do I fix this?

  • $\begingroup$ The first testscene that went good has much lesser memory consumtion than the more complex scene in the second test. I guess your GTX 960 has about 2048 MB dedicated Memory... so i think you run out of GPU Memory with that scene. Did the other guy with the Card render the same scene? $\endgroup$ Commented Aug 25, 2016 at 21:23
  • 1
    $\begingroup$ Also, note that many cards come in dozens of variations, so they may have had a 4, 6, or even 8GB version $\endgroup$
    – J Sargent
    Commented Aug 25, 2016 at 22:22
  • $\begingroup$ yea he rendered same scene $\endgroup$ Commented Aug 25, 2016 at 23:38
  • $\begingroup$ The fact that someone else with the same card can render doesn't mean much, unless your computers are configured exactly the same way. In any case when you run out of memory it means only one thing: your scene exceeds the resources available to render it. Your options are 1-Simplify the scene, 2- Render using the terminal. 3 render using CPU. In any of those cases is always wise to close all other apps and not use the computer while it is rendering. $\endgroup$
    – user1853
    Commented Mar 29, 2017 at 14:11

2 Answers 2


There are two options.


Your scene render is bigger then your GTX 960 memory.


Change render to CPU.


You have active 'render preview mode' and 'final render' at once.


Turn off 'preview mode' or change it to 'solid/wireframe'.

  • $\begingroup$ Didn't seem to work. why did the other GTX 960 didn't run out of memory or have to change any blender settings but mine I seem to have to do so? $\endgroup$ Commented Aug 25, 2016 at 23:44
  • $\begingroup$ Maybe you have another software using it hardly in the background? Minimized game or something? $\endgroup$
    – cgslav
    Commented Aug 25, 2016 at 23:45
  • $\begingroup$ Tried it, I lowered the title size to 128x128 and got lot furthure still ran out eventully $\endgroup$ Commented Aug 26, 2016 at 1:07
  • $\begingroup$ Could you post in edit screenshot from Windows Task Manager while render is on? Detailed view, Performance tab and Processes. $\endgroup$
    – cgslav
    Commented Aug 26, 2016 at 1:22

I discovered this can happen when a file is corrupted as well. I built really huge neighborhood scene with lots of linked files. I thought it was because I did a high poly tree for my scene that my card couldn't handle it so I started separating everything, same thing with grass etc. But it seemed that computer could handle less and less. Would work fine rendering a tree by it's self, grass by it's self but the regular scene that it never problems before rendering would have this CUDA error. ****When I discovered that it would not render a hedge that is in my scene by it's self, then I realized that the problem was with linked file*. I had the original in a completely different folder, I rendered it and it was very fast. So I just saved that file over the one that is corrupted, made sure that the texture is also re-assigned from the new place. Problem solved, no more real issues. As matter fact the scene was rendering pretty fast with everything at (2K).***. *If you still have a problem rendering something, make sure that you clean computer from registries etc. and sometimes you might have to close down other programs if there still is a problems. This so far works for me.

  • $\begingroup$ "clean computer from registries"?.. The message says "Out of memory". Do you think it might be that it just runs out of memory? I think that would make sense. $\endgroup$ Commented Jul 11, 2019 at 19:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .