2
$\begingroup$

The images have alpha channel checked on. In normal view the image looks fine but when I render the images cutoff the ones behind it.

enter image description here

There should be no gap between those 2 images but the one closer to the camera is cutting off the one behind it. I used the import images as planes addon. My goal is to export a png file that is transparent except for the colored areas. I'm gonna import this file into Unity so it needs to have a transparent background.

$\endgroup$
2
  • $\begingroup$ Could you upload your .blend or a screenshot of your material settings? I'm guessing that you are using BI and don't have transparency enabled in your material settings (or if you do, then it's set to mask). If that is the case, try Z-transparency instead. $\endgroup$
    – gandalf3
    Jun 27, 2014 at 5:53
  • $\begingroup$ Yes changing it to Z transparency fixed it at least when I go to Render- Render Image. I hope this is how it'll save. $\endgroup$
    – luigi
    Jun 27, 2014 at 19:26

2 Answers 2

2
$\begingroup$

You must enable Transparency in the material settings:

enter image description here

Using mask transparency won't work because it renders sky where there is transparency.

$\endgroup$
0
$\begingroup$

Starting with the basic z-transparency settings from this answer: Why does a multiplied texture with alpha loose detail information?

In the material settings' Shadow tick Receive Transparency and disable Cast.

The first image shows the same situation as in your post. The transparent parts of the texture cast a shadow:

enter image description here

enter image description here

enter image description here

Now there is no longer a shadow casted from the transparent part, but might also want to remove the shadow from the opaque image.

enter image description here enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .