12
$\begingroup$

I am using a series of .png images (from green screen footage) with alpha channels. However, when I try to import image(s) as plane(s) in a rendered scene, the image is blurry with anti-aliasing off. If I turn on anti-aliasing, then I get a frame artifact around the image plane.

Also, is there a way to setup the plane so objects behind transparent parts of the image can be seen? I am using Blender Internal and an AMD Radeon HD 5770 graphics card.

$\endgroup$
  • 1
    $\begingroup$ Welcome! I modified your original title to narrow the scope a little, some details were conveyed in the tags already. $\endgroup$ – zeffii Jun 13 '13 at 11:49
10
$\begingroup$

Nice default settings are to make sure you have Z Transparency as shown below in the Alpha Mode group.. also tick Shadeless as this makes them insensitive to light or shadow and will make them not appear blurry when rendered. You can enable this before or after importing the image(s).

enter image description here

The images come in clean with the alpha setup nicely. As you can see, they can also be layered etc, they might look a bit aliased in the 3d viewport but when rendered show very nicely.

I think the artefacts you might have seen is because they are intersecting with each other, try spacing them apart a bit on the Z axis etc..

These are the planes below in the 3d viewport after importing, the ones on the left have been spaced, while the ones on the right are in the default position.

enter image description here enter image description here

This is how they look without Shadeless enabled when rendered.

enter image description here

And this is how they look with Shadeless enabled when rendered.

enter image description here

$\endgroup$
  • 2
    $\begingroup$ PNG images in general should not be set to Premultiplied alpha mode, as they are Straight alpha according to the PNG specification. If that part didn't solve any problem I suggest to remove it from the answer. $\endgroup$ – brecht Jun 13 '13 at 18:44
  • 1
    $\begingroup$ @brecht as I did not know exactly how his setup was, I merely added it just in case. Duly noted, I think the shadeless bit was what he had problems with. $\endgroup$ – iKlsR Jun 13 '13 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.