1
$\begingroup$

I am exporting a PNG from a basic scene at 1000*1000px resolution.

I am using a combination of a ground plane as a shadowcatcher, render properties -> film -> transparent is checked, and compositing to make the background transparent. The Output Properties are also set to PNG with RGBA color. Render engine is cycles. In the object settings for the shadow catcher, I have disabled glossy ray visibility so that the reflection doesn't show in the surface of the object.

This should output a PNG with a totally transparent background, however when I place these PNG's onto a coloured background, the 1000*1000px border can be seen as the whole area is filled with a very faint grey colour. You can see it in the images attached; transparent PNG on a yellow background but you can clearly make out the frame of the image.

What setting is causing this? I did not create the original blend file, but something in it must be causing this as other PNG's from other blend files export PNG without this issue.

BLEND FILE:

enter image description here enter image description here enter image description here

$\endgroup$
1
  • $\begingroup$ it's something to do with the compositing nodes. When I disable "use nodes" in compositing, the background is fully clear.... Anyone know what is causing it? $\endgroup$
    – ScottF
    Mar 7 at 4:57

1 Answer 1

3
$\begingroup$

The problem is, either intentionally or accidentally you have changed the default start and end values on the RGB Curves node. The width of the node is maybe too narrow to see it clearly, but if you make it wider you see the following:

You have basically mapped a [0.01111, 1] input range to a [0, 0.98125] output range. The left control point outputs Y = 0 up to X values of 0.01111, while the right control point for X = 1 does not output values higher than Y = 0.98125, which is not fully white:

rgb curves

And there is the problem: when the brightest output of the RGB Curves node is not white, but light grey, then inverting the colors afterwards results in a very dark grey, but not black - therefore the background is not fully transparent.

So I guess the left point does not matter very much if you do not mind the opaque parts of the shadow to be still slightly transparent (if there were opaque shadows). But I would definitely set the right point to Y = 1, this will help.

$\endgroup$
1
  • $\begingroup$ Gordon thank you again for the solve! Seems obvious now. $\endgroup$
    – ScottF
    Mar 8 at 1:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .