3
$\begingroup$

The pivot point of every vertex in the mesh of my object is out of position for some reason how do I put it back to where the geometry of my vertex actually is. I tried origin to cursor but it will say you could not do apply this in edit mode.

enter image description here

As illustrated in the picture above the pivot point is far from where the vertex is located.

$\endgroup$
  • $\begingroup$ Yes the 3d Manupalor's origin is what I am talking about. here is the copy of my .blend file. link $\endgroup$ – user4956 Jun 26 '14 at 9:01
3
$\begingroup$

This is because the armature modifier is not taken into account (this is intended behavior), so the pivot point is at the non modified location of the selection.

This becomes obvious when toggling Modified edit cage (the triangle icon on the modifier):

enter image description here

To make things more manageable, try disabling the modifier in edit mode:

enter image description here

Also see Why is vertex snapping with auto merge enabled not merging vertices?

| improve this answer | |
$\endgroup$
0
$\begingroup$

Switch out of edit mode back to object mode and try the "Origin to 3D Cursor" operation again. It should work.

| improve this answer | |
$\endgroup$
  • $\begingroup$ yes it works but that is not what I wanted to do. I want to fix each vertex so that the pivot of every vertex is in its center. Not the pivot of the whole 3d object itself. $\endgroup$ – user4956 Jun 25 '14 at 16:51
  • $\begingroup$ You can assign every vertex of a mesh to be a pivot point, but only one at a time. You do this by setting the pivot point to "active element", and selecting the vertices as you want to change the pivot point. Just as you cannot have more than one active element at a time, you cannot have more than one pivot point at a time. $\endgroup$ – brasshat Jun 25 '14 at 18:52
  • $\begingroup$ well the problem is when I snap using the magnetic too from vertex to vertex. It does not snap correctly, it snaps to the point where the pivot seems to be located. This is happening in all vertices $\endgroup$ – user4956 Jun 25 '14 at 20:07
  • $\begingroup$ @user4956 Do you have any modifiers? $\endgroup$ – gandalf3 Jun 25 '14 at 20:31
  • 1
    $\begingroup$ @brasshat I posted the link to the file above $\endgroup$ – user4956 Jun 26 '14 at 11:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.