2
$\begingroup$

I'm trying to bake the lighting onto this scene, I believe I did all the steps correctly, but the texture I get when I press Bake just comes out as these diamond-shaped blobs. I tried to google and look around, but I can't find anything.

The model I'm using was made from just a plane so the bottom of it is hollow, it's all joined as one piece, save for a few point lights I put inside the houses with translucent windows as an experiment. I also have 2 sun lamps and some of the windows are using an emission material.

I checked the normals and they all seem right, I switched on Backface Culling for a second to make sure.

Is there something I'm missing in the baking settings or something? Are there things in the scene that aren't compatible with baking? I've never changed it so I'm pretty sure it's set to the default. I followed a tutorial by Blender Guru and it looks like all the same settings, so I don't know what the problem is.

Thanks for any help.

enter image description here

enter image description here

enter image description here

EDIT:

I added a world color and closed of the bottom of the mesh, the last image is the current baking result and all my settings. A little more of the texture managed to actually bake, but it's grainy and messed up looking.

enter image description here

I added an image texture node to all my materials and this is what I got now lol

EDIT 2:

Okay, so I added the image texture node to all my material and then I selected the actual mesh in edit mode, then I baked it, and it seems to have actually worked. Now I'm just messing with the clamping and the sampling to get ride of the fireflies and graininess and it seems to have actually worked. So problem solved.

enter image description here

$\endgroup$
  • $\begingroup$ Welcome, @fdd. Did you add a world color? It looks like only the interior lights are baked. $\endgroup$ – LeoNas Sep 28 '18 at 11:53
  • $\begingroup$ @LeoNas Hi, I just added one and it seems I'm getting the same result. I also closed up the bottom of the model and it seems to have baked a little more of the texture, but not much, and it's grainy and strange looking. imgur.com/a/clGqeuL $\endgroup$ – fdd Oct 2 '18 at 1:40
  • $\begingroup$ @LeoNas nevermind, i figured it out $\endgroup$ – fdd Oct 2 '18 at 3:11
  • $\begingroup$ @mr-zak ok sure $\endgroup$ – fdd Oct 3 '18 at 5:23
0
$\begingroup$

add an image texture node to all the materials, select the mesh in edit mode, then bake it

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.