This previously worked fine, however now any time I bake, I just get a black texture and I have no clue why. I tried looking for answers but their proposed solution didn't do anything for me.

Here's the node setup:

node setup

It looks like this on my model:

it's a bump texture where I combine a bunch of things like skin bumps and pores.

Then, I select the object and select this image:

the target image.

Here are the bake settings:

bake settings

And the render settings as well:

render settings

After hitting 'bake', the image just turns black:

black texture result

Thanks in advance.


1 Answer 1


Solution was to open the console (window > toggle system console) and look for errors.

In my case, I had errors where blender tried to open a file in a directory that didn't exist. Creating the directory manually solved the issue.

The error looked like this:

E0504 03:11:14.022554 27532 tile.cpp:464] Error opening tile file: Could not open "C:\Users\[username]\AppData\Local\Temp\blender_a42480\cycles-tile-buffer-6356-1883955203000-12-0.exr" (No such file or directory)
Error writing tile to file

The solution is to open terminal or cmd and execute:

mkdir C:\Users\[username]\AppData\Local\Temp\blender_a42480\ and try baking again.

Or, just navigate to the folder through explorer or whatever.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .