4
$\begingroup$

I was wondering how to turn off image tiling for textures in the game engine. My UV map would make it tile right now (i.e. it's bigger than the map), but I can't figure out how to turn tiling off. I'm using the game engine with GLSL enabled.

$\endgroup$
  • $\begingroup$ Just curious as pertaining my answer below. Your question is worded funny. Texture tiling and (tiling textures) can be interpreted as two different things.. please clarify exactly what you mean. $\endgroup$ – iKlsR Jun 17 '13 at 14:02
3
$\begingroup$

In the UV Image Editor, bring up the properties toolshelf with N and under Game Properties, under the Clamp group, tick X and Y, you can now scale your map larger than your image without tiling your texture..

enter image description here

$\endgroup$
  • $\begingroup$ Is there something I need to do in the texture settings also? It's still tiling. $\endgroup$ – CharlesL Jun 17 '13 at 14:13
  • $\begingroup$ @CharlesL hmm.. this worked for me, you could try under texture settings, change Image Mapping to Clip and also make sure that your mesh is unwrapped properly (the default unwrap) and under Mapping, Coordinates is set to UV. $\endgroup$ – iKlsR Jun 17 '13 at 14:14
  • 1
    $\begingroup$ Ah, it was working before, it just wasn't updating. Changing the shading settings to singletexture then back to glsl updated it. $\endgroup$ – CharlesL Jun 17 '13 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.