I have a tiling texture that I prepared for use as a bump map.

The problem is that it's too big!

I want the texture to display on the model at about 1/8th of the present size, but I can't figure out how to scale it to be finer. The bump map is supposed to resemble fabric fibers, but at present it just looks like scaly clumps because it's too big.

How can I change the mapping to fix this using Cycles nodes without altering my UV map? If this were a procedural texture I could just change the scale value, but I'm not sure what the equivalent approach would be with an image texture.


The texture tiling on the UV coordinates is too big and needs to be scaled down

  • $\begingroup$ In the Node Editor add a Mapping node (Add-->Vector-->Mapping) and change the texture scale. $\endgroup$
    – Paul Gonet
    Commented Oct 12, 2015 at 22:50
  • 1
    $\begingroup$ @Gonzou Thanks! I was figuring this out as you posted your comment. I should have thought of it sooner, but for whatever reason the existence of the Mapping node had escaped my mind at the time. $\endgroup$
    – Mentalist
    Commented Oct 12, 2015 at 22:57

2 Answers 2


This can be solved by inserting a Mapping node and setting the Scale values as desired.

Texture scale fixed with the Mapping node

Close-up of the Mapping node and its settings

  • 4
    $\begingroup$ Nice selfie man :). $\endgroup$
    – Paul Gonet
    Commented Oct 12, 2015 at 22:58
  • 6
    $\begingroup$ For those confused on why increasing the scale numbers makes the texture smaller here's a hint: the default value for the scale node is one, meaning that the texture will fit one time along the mapping coordinates, by changing the scale to 8 means that the texture will be 8 times smaller... $\endgroup$
    – user1853
    Commented Oct 12, 2015 at 23:01
  • 3
    $\begingroup$ And changing the method to texture does it the way that most people expect. $\endgroup$ Commented Oct 12, 2015 at 23:01
  • $\begingroup$ In Blender 2.8 this appears to just shift the texture around not scale it. At least sof far. $\endgroup$ Commented Dec 8, 2018 at 9:08
  • $\begingroup$ This is nice. Is there any trick to not get the texture tiling if it is scaled smaller? $\endgroup$ Commented Jan 4, 2021 at 10:06

There is a much easier way for those who don't want to use the node editor. In Cycles Render: - Unwrap your image (at this stage you have at least 2 panel views, 3d and UV) - MATERIAL (add your image by clicking on the little circle at the far right button of COLOR. -switch to TEXTURE:(your chosen image should already be there, if not select it by clicking on the icon - Browse image to be linked - in the Node section. Go down to MAPPING: You will see Location, Rotation and Scale. Play with the Scale on the x, y and z axes. The changes will be visible in real time in the 3d view pane.

For a detailed tutorial with photos, visit this link: Scaling Images in Blender

  • $\begingroup$ This is a fantastic answer and should be the accepted answer. Changing the scale in the node editor should only be done as a last resort. $\endgroup$ Commented Apr 16, 2020 at 7:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .