4
$\begingroup$

So I made a basic scene composed of point lights and a plane to test my textures in the blender game engine along with a basic fps camera. the problem that i have is when i play the game using the embedded player, textures look fine (diffuse, normal and specular), when i use the standalone player it works fine too but when i use fullscreen mode in the standalone player the textures are the only thing that looks blurry. i tried changing resolution, using diffuse texture only, updating blender but non of that worked.

Im using GLSL shading btw

this is how its supposed to look like: how the texture is supposed to look

but in fullscreen mode (using the standalone player) it looks like this: fullscreen (the monkeys are there to see that the blur does not affect game objects, only textures).

does anybody have a solution, it would be really helpfull.

thanks.

$\endgroup$
  • $\begingroup$ Is the result the same if you disable anisotropic filtering? $\endgroup$ – xlxs Sep 13 '16 at 15:43
  • $\begingroup$ if you are talking about the settings like the ones on this post's answer: blender.stackexchange.com/questions/6683/… i dont have those settings $\endgroup$ – Walid Laribi Sep 13 '16 at 16:09
  • $\begingroup$ It looks like you have "mip maps" enabled in the sampling settings for the texture. $\endgroup$ – JakeD Sep 13 '16 at 17:28
  • $\begingroup$ can you send a screenshot, i cant see where it is. $\endgroup$ – Walid Laribi Sep 13 '16 at 17:33
  • $\begingroup$ I did a short experiment. It looks like the lower mip-map level starts as twice as early in full screen compared to window at the similar resolution (due to the border it is not the same at my system). $\endgroup$ – Monster Sep 14 '16 at 6:55
1
$\begingroup$

You need to activate anisotropic filtering in Blender's system settings.

Hit Ctrl+Alt+U, go to the System Panel and change the settings under Anisotropic Filtering to 2 or higher.

enable anisotropic filtering

$\endgroup$
  • $\begingroup$ it was already on, i set it to max and it didnt fix it. the problem might be the same as in this article's answer but i dont have those settings, can you help? $\endgroup$ – Walid Laribi Sep 13 '16 at 16:56
  • $\begingroup$ @WalidLaribi - not without the file to work with. You might upload it to blend-exchange.giantcowfilms.com and add the given link to your question. $\endgroup$ – metaphor_set Sep 13 '16 at 16:59
  • $\begingroup$ here is the link for it: <img src="http://blend-exchange.giantcowfilms.com/embedImage.png?bid=1954" /> $\endgroup$ – Walid Laribi Sep 13 '16 at 17:24
  • $\begingroup$ I just tried your file and set the anisotropic filtering in the system settings all the way up to 16. Looks good that way - aka visible difference. Other than that there's nothing wrong with your material settings. $\endgroup$ – metaphor_set Sep 13 '16 at 17:52
  • $\begingroup$ yeah i see the difference as well, but there is no difference when playing with the standalone player @metaphore_set $\endgroup$ – Walid Laribi Sep 13 '16 at 17:58
1
$\begingroup$

Try:

from bge import render

render.setMipmapping(2)
render.setAnisotropicFiltering(16)

On my system these settings do not show up in the game engine unless they are set through the python API.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.