0
$\begingroup$

I use Blender 2.79 on Ubuntu 16.04 with an AMD Radeon RX 560 GPU. However, Blender doesn't detect my GPU as a "Cycels Compute Device". My approach is listed below:

  1. Installation of Ubuntu 16.04

  2. Installation of AMD GPU driver

My terminal output from is:

*-display

description: VGA compatible controller
product: Advanced Micro Devices, Inc. [AMD/ATI]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:01:00.0
version: cf
width: 64 bits
clock: 33MHz
capabilities: vga_controller bus_master cap_list rom
configuration: **driver=amdgpu** latency=0
resources: irq:26 memory:d0000000-dfffffff memory:efe00000-efffffff ioport:ee00(size=256) memory:fba80000-fbabffff memory:c0000-dffff
  1. Download Blender 2.79 from Blender.org

  2. Open the Blender User Preferences

    The System Tab in the window Blender User Preferences displays None as the Cycles Compute Device.

I am not shure whether I'm doing somthing wrong or whether it is a bug. I would appreciate any help on this subject because I would like to render with my GPU.

$\endgroup$
1
$\begingroup$

Solution:

Install OpenCl Packages.

For Arch Linux: libopencl and opencl-amd

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.