0
$\begingroup$

I am failing to render with Cycles. When I hit F12 in a default scene (just a cube) it says "CUDA kernel compilation failed, see console for details." I read that you can pull down from the top of the Blender window to see the console, but that didn't contain anything of value other than the same error message. So I started Blender from the terminal and got the following:

CUDA version 9.10 detected, build may succeed but only CUDA 8.0 is officially supported. Compiling CUDA kernel ... "nvcc" -arch=sm_20 --cubin "/usr/share/blender/scripts/addons/cycles/source/kernel/kernels/cuda/kernel.cu" -o "/home/tim/.cache/cycles/kernels/cycles_kernel_sm20_F85D76AC61003DDA20889AF653A705B3.cubin" -m64 --ptxas-options="-v" --use_fast_math -DNVCC -D__KERNEL_CUDA_VERSION__=91 -I"/usr/share/blender/scripts/addons/cycles/source" nvcc fatal : Value 'sm_20' is not defined for option 'gpu-architecture' CUDA kernel compilation failed, see console for details.

From googling it seems that sm_20 means "Compute 2.0" (which my GPU supports) and that as of CUDA 9 sm_20 is no longer supported. So are my only options to try and install CUDA 8 via nvidia's site or upgrade the GPU in this machine? Thanks!

Software:

  • Blender 2.79b
  • 64-bit Ubuntu 18.04.1 TLS
  • proprietary driver: nvidia-driver-390
  • nvidia-cuda-toolkit version 9.1.85-3ubuntu1
  • nvidia-modprobe version 384.111-2

Hardware:

  • Nvidia GTX570, Intel 6600K, 16GB RAM

Blender Setup:

  • Preferences > System > Cycles Compute Device is set to "GeForce GTX 570 (Display).
  • Render button's device is set to "GPU Compute"
  • Cycles Render is set at top of 3D view.
$\endgroup$
0
$\begingroup$

Seems like GTX570 cards are no longer supported in Cycles. You should still be able to render on them in previous versions of Blender. I think 2.77 or 2.76 should still work. Else than that unfortunately I don't think there is a solution for this other than upgrading to a newer card.

$\endgroup$
  • $\begingroup$ I gave 2.77 a try and the GPU rendering started working, but it ran out of memory on the default scene. Thanks for the help! $\endgroup$ – Tim Aug 22 '18 at 0:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.