1
$\begingroup$

So I'm working out the kinks of a brand new Linux build. Very much a noob, but have been researching and writing notes on Debian/Ubuntu for several months.

I've been carefully going through each software that I know I want to optimize and have been trouble-shooting everything to the best of my novice ability.

  • My build runs the latest 20.04 release of Pop!_OS, which is built upon Ubuntu 20.04
  • AMD Ryzen 7 3800x 32GB DDR4 3600mhz Ram
  • NVIDIA RTX 2070super (Gigabyte brand)
  • MSI Gaming Edge WIFI mobo

My problem is that Blender doesn't seem to recognize my GPU, even though all forum users I've come across, including on here, say that anything with a Compute value at or higher than 3.0 will be supported, and state no other possibility for an incompatibility. Yet the preferences window doesn't recognize any CUDA cores, and says it will default to the CPU.

"No compatible GPUs found for path tracing. Cycles will render on the CPU"

As I said, I'm running the latest release of Pop!_OS, my NVIDIA driver is the latest 440 driver release, and Blender is up to date for my package manager.

Could this be a glitch with Blender 2.82a? A glitch between Blender and Linux and my brand of GPU? Are the super variants of RTX cards not treated the same inside Blender as the main-line cards?

These are my only guesses, but I don't know if there's anything I can try.

enter image description here

enter image description here

$\endgroup$
1
$\begingroup$

Edit:

Downloading 2.83.1 directly from the Blender website (not Pop!_Shop) fixed it for me.


Not an answer, but I have a similar problem. My 2070 Super is not recognized for CUDA rendering in Blender 2.83. I downloaded 2.82a and it works fine. This is odd.

I use Pop!_OS 20.04 as well.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.