0
$\begingroup$

First time posting here and virtually brand new to Blender. My first project was a fairly significant one and I basically followed this tutorial. However, as the tutor didn't mention his render settings, I tried various ones myself but failed to produce the detailed result he presents.

Included are some screenshots of output and render settings along with camera settings. I'm including camera settings because the rendered image does not appear like the one shown here as there is an extra shadow present.

You can see that the resolution is 1920x1920 at 100%. I tried 200% here which did produce a more detailed planet, but only a small portion and it took forever to render. For output, under the render section, I have the samples set for 2. Originally, this was like 100+ but it would have taken days to render!

Suggestions for better settings for output, render, and even camera would be welcome. At least I was somewhat able to come up with a similar gas giant to the tutorial but will need tweaking of the various nodes.

Thanks in advance!

EDIT: My video card under Ubuntu 22.04 has the following specs:

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV670 [Radeon HD 3870] (prog-if 00 [VGA controller]) Subsystem: Dell RV670 [Radeon HD 3870] Flags: bus master, fast devsel, latency 0, IRQ 39 Memory at d0000000 (64-bit, prefetchable) [size=256M] Memory at fe9f0000 (64-bit, non-prefetchable) [size=64K] I/O ports at dc00 [size=256] Expansion ROM at 000c0000 [disabled] [size=128K] Capabilities: [50] Power Management version 3 Capabilities: [58] Express Legacy Endpoint, MSI 00 Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+ Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?> Kernel driver in use: radeon Kernel modules: radeon, amdgpu

enter image description here enter image description here
enter image description here

Thanks, all. I think I have it pretty much worked out and thanks for the tips. After experimenting with the rendering, I believe I can now get a reasonable working result. I am encountering a new issue however and that is that the shadow I'm seeing in shader with the camera on is not the same as the rendered shadow, which is incorrect and ruins the image. I have attached a screenshot. I can't see where I have anything extra enabled as there's just one light, sunlight, so your thoughts welcome.

incorrect shadow during render

$\endgroup$
7
  • $\begingroup$ Have you checked basic tutorials on render settings? 2 samples is nothing, you don't seem to have your GPU set up for render acceleration, ... There are many resources that talk about it, including on this very website. $\endgroup$
    – Lauloque
    Jan 10 at 17:59
  • $\begingroup$ Resolution is just how big your picture is. If you don't need more than 1920x1080, don't do more. Samples is the core of the render's quality. You should definitely go way beyond 2. A hundred + denoising can de a good starting point. $\endgroup$
    – Lauloque
    Jan 10 at 18:00
  • $\begingroup$ Unfortunately, "GPU Compute" is shaded out and a quick check of the system- cycle render devices shows "no compatible GPUs found for cycles" for any of the four tab selections besides "none." I've added my video card specs to my original post. Unfortunately, it looks like I may not be able to use Blender. $\endgroup$
    – Eric
    Jan 10 at 18:27
  • $\begingroup$ Hi Eric :). Volumetrics take the longest to render, so perhaps not the best choice for lower specs hardware. You can check some YT tutorials, and also remember, you can render while you sleep :)) $\endgroup$ Jan 10 at 20:19
  • $\begingroup$ Encountering a new issue now with incorrect shadowing during render. I have edited my post above. Thanks for the tips on the other things. I believe I have sampling and sizing worked out now. $\endgroup$
    – Eric
    Jan 11 at 5:16

1 Answer 1

0
$\begingroup$

If you are not using (and from what I can see you are not) depth of field, camera options shouldn't affect much the render time.

Tho from what I can see your graphic card is unfortunately not the strongest. I would even said its pretty bad for rendering, but i have some tips:

  1. set noise treshold to 0.1 (currently 0.01). It may effect quality, but on the still image should be that visible, it is more visible on animation.
  2. Max samples shouldnt be at 2. Depends on the lightning on your scene (stronger light=less noise=you don't need taht much samples) you can set them to something lower, but I would say never lower than 64 and 64 is still pretty low.
  3. go to edit>preferences>system and check cuda/optix and if you graphic card will be visible there select it and try if it sped up the render a bit.
  4. Percentage under resolution does not meant quality but what % of the resolution you are want to have. For example if you set 1000×1000px and set 20% you will get 200×200px image.
  5. Try using your CPU instead of GPU, but assuming you have older GPU your CPU probably is not the strongest as well, but it might be worth a try.
$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .