1
$\begingroup$

I retopologized my shotgun model, then I marked seams and unwrapped it, but the UV map seems to have a white background.

I have tried resetting the UV and unwrapping again, but that changed anything. I have also tried making a fresh blender file and importing the gun and after unwrapping it again, nothing changed, so that means that it is not a file-specific issue.

What's is that when hit A on my keyboard so select everything and then move the whole thing, the white background moves too and shows the normal UV grid behind it.

Another thing that is odd is that when I hit Ctrl-A to average the Islands Scale, it removes the white background and messes up my UV layout.

How do I fix this?

My shotgun seams: enter image description here

In the UV editor window: enter image description here

$\endgroup$
  • $\begingroup$ That white background is not a background but a bunch of full sized faces stacked up. $\endgroup$ – David May 4 '18 at 18:31
  • $\begingroup$ How would make these "full sized faces" disappear? $\endgroup$ – cgperfect May 4 '18 at 18:36
  • 1
    $\begingroup$ In short part of your modal is not unwrapped properly. You might have internal faces, or just some small faces you never selected. Move some of the correctly unwrapped islands out of the way, then select one of the big faces, and see where it is on our model. $\endgroup$ – David May 4 '18 at 18:43
  • $\begingroup$ Problem solved, it turns out i just forgot to UV unwrap a part of my mesh. Is was the sights, which didnt use a texture so i didn't bother to UV unwrap it either. $\endgroup$ – cgperfect May 4 '18 at 18:51
1
$\begingroup$

It's clearly part of your unwrapped mesh that is projected as a plane, you can see vertices at each corner of the uv editor, you can turn on sync the uv and mesh selection by clicking the button shown in the image attached, then select a vertex at a corner, press ctrl+L to select the linked vertices, then you can go to the 3d view and unwrap that part of the mesh correctly.enter image description here

$\endgroup$
  • $\begingroup$ I have tried this and it says when i hit cntrl+L: Selection Linked only works in face select mode $\endgroup$ – cgperfect May 4 '18 at 18:33
  • $\begingroup$ Also all the meshes are one object $\endgroup$ – cgperfect May 4 '18 at 18:41
  • $\begingroup$ You can manually select the vertices at the corners, go to the 3d view the and click View>Align View>View Slected $\endgroup$ – Ninjabdou May 4 '18 at 19:07
0
$\begingroup$

It turns out the problem was that some parts of my model were not marked seams and UV unwrapped. I didn't unwrap some of the parts of the model because it did not have a texture, and because of not unwrapping it, the parts that were not UV-Unwrapped became a "background" in the UV editor window. Once i unwrapped it, the problem stopped.

$\endgroup$
0
$\begingroup$

Problem:

Object is completely white in UV map on unwrapping,

Solution:

press A to select whole object and unwrap it again.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.