0
$\begingroup$

I have retopologized a shotgun and marked all the seams where they are supposed to, and then Unwrapped it, and instead of getting nice UV's, i get this:

enter image description here

Here are the seams:

enter image description here enter image description here

I have tried Applying the scale, Averaging Island Scale, Packing Islands, and minimizing stretch, and Smart UV Project, and Lightmap pack, all of which slightly helped, but not enough. What is wrong?

$\endgroup$
2
  • 2
    $\begingroup$ Could you highlite the geometry connected to the problematic UV island by keeping the selection in sync? $\endgroup$
    – Carlo
    Commented May 4, 2018 at 23:41
  • $\begingroup$ Do a "remove doubles" clean up operation on your mesh and unwrap again and see what happens. $\endgroup$
    – R-800
    Commented Jun 6, 2020 at 11:42

2 Answers 2

1
$\begingroup$

Those lines stretching from an island to another could be caused by a single missing edge mark, or that after doing the UV Map you picked up a couple of tris and turned them into quads and those triangles where from different sets of islands.

$\endgroup$
1
  • $\begingroup$ I am sure i marked everything, but i will review it again just to make sure. $\endgroup$
    – cgperfect
    Commented May 6, 2018 at 1:27
0
$\begingroup$

Some steps could fix your problem:

1-Apply Rot & Scale to objdata. (CTRL+A in object mode)

2-Make Normals Consistent. (CTRL+N in edit mode)

3-Remove double vertex. (CTRL+V+Remove Doubles in edit mode)

4-Recheck your topology, maybe you have N-Gons or Triagles that are messing the Unwrap.

That's all I can think of now, hope it helps.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .