1
$\begingroup$

My situation

I have a fluid sim in which a cube standing in a puddle enter image description here

melts entirely into a puddle enter image description here

To make the melting simulation more realistic i set the speed of the fluid sim to a very slow pace.

The next step is to add more fluid from an inflow. For this i want to make a new fluid simulation which already contains the final puddle of the melting simulation and grows from an inflow.

My problem
When i was trying to copy the final puddle of the melting animation and start a new one with it, it seems like the old baking data still remain.

To copy it i selected the puddle in the frame i needed it from and used shift + d to copy the object. Then i applied the fluid modifier to remove all its physics. I set a new domain and baked it again.

For some reason the new fluid sim still contains the cube of the old one, even tho the fluid object i copied and created isn't a cube. enter image description here

What i have tried so far to fix it

  • Removed all the simulation settings (including obstacle, fluid and domain) and set them new
  • Removing the cache folder of the blender save files
  • Renaming/Changing the save files locations
  • Recalculating normals

Here is my .blend file

Can anyone tell me where those old bake data come from and how i can get rid of them so i can finally get on with my life

$\endgroup$
  • $\begingroup$ In the blend file you provided, you still have an object called "Ice Cube" with the fluid sim active (type "Fluid"). The object is set to non-visible / non-rendered, but it's there. Remove the fluid sim from this object and the cube shape disappears when baking the sim (when I tried it). $\endgroup$ – risingfall Feb 18 '18 at 17:20
  • $\begingroup$ @risingfall must have overlooked it multiple times, wow. Thanks for spotting it. $\endgroup$ – Basti Feb 25 '18 at 17:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.