0
$\begingroup$

First of all: I am new to Blender. I installed it today. After a few basic things I wanted to try out the fluid simulator. The first simulation worked fine, just like in that tutorial. The simplest of setups: a not-too-big-sized cube as the domain, a small sube as the fluid. Baked it and watched the finished preview.

Then I started over (Ctrl+N), took the default cube and enlarged it a little bit. As soon as I changed the type of that cube to "domain", it took the shape of the former fluid cube. After I deleted the fluid-cache files manually, the cube stayed the way it was when I changed the type to domain.

Is this a normal behaviour?

And it obviously isn't enough to delete the fluid-cache files. After I hit "bake", the domain cube immediately changed its shape to the first fluid cube and stayed the entire simulation like this. It only "tried" to move a few mm, as it seems. Quittung the application and restarting it doesn't help. Somewhere the data from the first test-simulation remains somewhere on my system, which btw is a Win10 PC.

What am I doing wrong?

$\endgroup$
0
$\begingroup$

Data for fluid sims is saved to external files, if the current blend is not saved this will be in a temporary folder, it may also get a temporary path if the domain is created before saving the blend file, even if the simulation isn't baked before saving. While this should use a random path name generated each time blender is run, there is a chance of old temporary data being used, thinking it is the current sim data.

The path used for saving sim data can be found in the domain settings. You can change the path to prevent the old data being seen.

enter image description here

While other simulations provide options to clear the baked data, the current fluid sim does not.

$\endgroup$
  • $\begingroup$ Thank you for your reply. Unfortunately, that didn't help. The irregular behaviour remains. I have tried many different sims, but every time the domain mesh disappears and becomes the fluid mesh and doesn't move except for the few jitters. After I hit "bake", it starts to calculate. When I move the time line cursor during the calculation I can see the selected domain mesh changing into the form of the fluid mesh ... $\endgroup$ – MH LI Oct 28 '18 at 22:28
  • $\begingroup$ ...and when I move the cursor beyond the baked state, the "fluid" goes back to being the domain mesh and the original fluid mesh didn't move or change. I really wonder what I have done wrong that the fluid simulator only worked the very first time (as it was shown in the many tutorials) and after that it shows this odd behaviour. $\endgroup$ – MH LI Oct 28 '18 at 22:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.