0
$\begingroup$

I am making a fluid sim with blender 2.77 (same result in 2.79) in cycles render. Water flows from a pipe into a pool and there are a few obstacles etc.

Now I have an issue if I set the quality factor high (100, 120, 150, 200) always the same result with different forms. Here the picture: Quality 200, 1-2 Subdivisions, 1.0-1.5 smoothing : enter image description here

The former picture looks good, though it still has the black shadow on the inflow water. Quality 80, 1 Subdivision, 1.0 smoothing

I am trying to get rid of the black spots/shadows in the water. The lighning is done mainly by the world and one lamp.

Thanks for any help.

$\endgroup$
  • 1
    $\begingroup$ can you please attach the blend file ? $\endgroup$ – Shams El-Deen Sep 11 '17 at 8:58
  • $\begingroup$ I solved the issue with the black stripe in the pool. I changed the container of the water domain from "both" to "shell" in the "Volume Initialization" settings. But still have issues with the inflow. $\endgroup$ – Slev1n Sep 11 '17 at 14:26
  • $\begingroup$ I am only allowed to post two links. So I deleted the second picture. $\endgroup$ – Slev1n Sep 11 '17 at 14:33
1
$\begingroup$

I solved both issues:

1, Getting rid of the black "stripe": Setting the container (the concrete surrounding the water) in the fluid simulation under the "Volume Initialization" settings from "both" --> "shell". enter image description here

2, Getting rid of the black surface of the water inflow: Setting the amount of "max bounces" at least at 8.

enter image description here

It is still not perfect, but definately an improvement.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.