1
$\begingroup$

I have a scene which contains a creek. This creek continues to the very bottom of the scene and has a depth of approximately 25 default cubes. I have my fluid domain that surrounds the inflow object, outflow object and also my creek.

The problem is when I hit the 'Bake' button (final frame - 65). The fluid simulation progress bar which appears above the scene gets stuck at 0 percent progress all the time. After a while it goes invisible again.

When I came up with this error I opened another project and created a default cube as domain and inflow and it worked! After that I returned to my creek project and did the same things and it didn't work.

I did some research on the web and a lot of people says that "you should play with the variables of domain" but there has to be a solid solution for this. This is my scene.enter image description here

$\endgroup$
  • 1
    $\begingroup$ Could the simulation be to complex for your hardware? Could it take more memory to process than what's available in your system. Please edit your question and provide more info like system specs, scene and fluid settings, blender screenshots, or possibly a blend file. $\endgroup$ – Duarte Farrajota Ramos Jul 4 '16 at 16:40
  • $\begingroup$ i have deleted the fluid objects after a while.i can only provide you my system specs.intel i7 3.4 ghz 8 core,gtx 960m 2gb and 8 gb ram.I dont think its because my system specs although im suspicious about is there any chance that multiple scene layers have influence on fluid baking. $\endgroup$ – Roveldo Jul 6 '16 at 8:26
1
$\begingroup$

I've had a similar situation while modeling a complicated scene in a bottle. It works eventually; but there seems to be some kind of pre-caching and precalculating involved which is related to the obstacle complexity. For me, on a reasonably good machine, I was at around 10 MB of memory with a lot of wiggling for the fluid to do, and it was close to a minute of wait time before the meter started to move.

I would suggest starting with some simpler subset of your scene, and verifying that the fluid simulation works as intended. I would also suggest at times of long 0% waits simplifying your modeling to rely on the fluid sim as little as possible.


$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.