0
$\begingroup$

I was following a tutorial on rigging and everything went fine until I tried to parent my mesh to the rig, only to discover that when I switch from edit/object to pose mode (before skinning the mesh), two lower leg bones change the original position. It looks like they are being pulled by the IK.

This causes deformation when I skin the model and I'm sure it will cause problems when animating. I kinda found a solution where I had to rotate these two bones in the pose mode (although the mirror poses wouldn't paste for some reason from one side to the other), but I am not satisfied with it and I'd like to know whether anyone has an answer for this.

Why did it happen? Is there any way to deal with it? Below you can find a couple of images that show the problem and here is a link to my .blend file.

Screenshot 1 Screenshot 2

$\endgroup$
1
$\begingroup$

When I have this problem I go to Pose Mode, select the bone concerned, shift it to where it's supposed to be, Press CTL-A and select - 'At Rest '.

Check it in Edit and Object modes to see it doesn't move back again. Do this for each bone that's out of place.

In your example I'd be rotating the bones above the yellow ones, which I think you might have tried already(?)

$\endgroup$
  • $\begingroup$ Thanks for your suggestion! I did try rotating the bones above the yellow ones. Nothing works though. But I appreciate the advice you gave, it might work in different situations :) I guess I will just need to rerig and see whether this comes up again. Perhaps I just made a mistake somewhere along the way and didn't even notice. Rigging = hell =/ $\endgroup$ – BlendGirl23 Jan 24 '18 at 3:37
  • $\begingroup$ Blender does have it's challenges :-) $\endgroup$ – Edgel3D Jan 25 '18 at 2:48
0
$\begingroup$

I actually figured it out! In case anybody else encounters the same problem. When rigging, I was using Ctrl + N -> View axis to align the bones with the view axis, so that their rotation is not messed up. I aligned them from both front and side view, and that's what caused the problem. As long as I align them only in the front view, it works!

$\endgroup$
  • 1
    $\begingroup$ In armature edit mode, Ctrl-N recalculates the bone roll. That means it alters the direction of the bones local axes, so it rotates the bone. Enable axes in armature display properties to see this as it changes. You can see the roll setting in the transform panel of the properties region N. $\endgroup$ – sambler Jan 26 '18 at 7:26
  • $\begingroup$ Yep, this is how I did it. Thanks for writing out the whole process :) $\endgroup$ – BlendGirl23 Jan 27 '18 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.