3
$\begingroup$

This question has been asked a few times in various forms here, but none of the solutions work for me. I have included a short video showing the issue, where I highlight everything.

https://youtu.be/OP9Q6qG978s

Video broken down:

  • Brand new install of 2.8 (even deleted the data in Appdata/Roaming/Blender Foundation/2.80)
  • Restriction Toggle for the armature is not disabled
  • 'Lock Object Modes' in Pose Mode whether On or Off doesn't fix it
  • Unparenting the mesh from the armature and reparenting doesn't fix it

Something I forgot to say in the video, importing that character mesh into 2.79 works and doesn't have any of these problems (opening a saved 2.79 project in 2.80 does not fix it either). Same with other character meshes I have tested.

I genuinely don't know what to do, and neither do my buddies who work with Blender regularly. I have been trying to fix this for 3 days now, and I am very frustrated as it's preventing me from working with any armatures.

Can't Select Bones in Pose Mode (Blender 2.8)

I can't keep my armature in pose mode when selecting another object

Why can't I select bones in pose mode

$\endgroup$
2
$\begingroup$

Try to disable "In Front" in Viewport Display in the Armature Tab - that worked for me

enter image description here

$\endgroup$
0
$\begingroup$

I had his same problem. So apparently this bug happens when you start a file with an older version of Blender and then load it into 2.8. What I would do is open a new blank file and just "append" or import it from your older file.

$\endgroup$
0
$\begingroup$

I had the same issue for a long time. It seems that you can select individual bones using the Select Circle tool instead of the standard Select.

enter image description here

I'm not sure if it's a bug or if it means that we should use it from now on. But it works.

$\endgroup$
0
$\begingroup$

I had the same problem just a moment ago. Imported character were working, but their duplicate pose was unselectable. I saved and restarted the software and it is now working. A bad answer but we all forget to do it first.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.