0
$\begingroup$

I have a boolean modifier with the following settings that is modifying the object outlined in green with the following settings:

enter image description here

where Cube.018 are the 'ribs' around the edges (they are all joined together in 1 mesh for simplicity

enter image description here

I'm trying to cut some holes in the main object (the ribs actually go into it a bit). As you can see, they all work fine up to when the ribs start intersecting with the extruding cylindrical object (that's actually PART of the green object; it was added in edit mode). Then it just starts going haywire with darker double surfaces (inverted normals? I tried flipping normals already though) and whatnot.

Any help is appreciated

EDIT: Not duplicate because nothing 'goes invisible' and as far as i can tell, nothing connects (although that may or may not be the cause of the double surfaced (?) faces. I also removed doubles for both meshes as well

EDIT 2: As requested by Mr Zak, here are some screenshots in edit mode and the blend file:

enter image description here enter image description here

$\endgroup$
  • 4
    $\begingroup$ Possible duplicate of Boolean Modifier not working $\endgroup$ – Duarte Farrajota Ramos Dec 28 '17 at 22:40
  • $\begingroup$ If it's the normals then why not for the ribs before the messed up ones? Also, if the culprit are doubles then why do I remove 0 when I try removing doubles? $\endgroup$ – user3576467 Dec 28 '17 at 23:23
  • 1
    $\begingroup$ Removing doubles depends on threshold of operator.. Normals are messed up if object e.g. has negative scale (Object mode > Ctrl+A to apply) There're no screenshots of meshes in Edit mode, no file to debug (blend-exchange.giantcowfilms.com), only screenshot of result. As of now this is a duplicate of linked question because there is general one showing common cases. In all the cases boolean problems are caused by incorrect (non-manifold) geometry, which is described there. In your specific case maybe it's due to intersecting geometry. $\endgroup$ – Mr Zak Dec 29 '17 at 0:03
  • $\begingroup$ Edited (blend and edit mode screenshots) $\endgroup$ – user3576467 Dec 29 '17 at 0:21
  • 1
    $\begingroup$ There isn't any difference between adding geometry in Edit mode or adding in Object mode and then joining objects, result will be the same. There is intersecting geometry in your file - second screenshot from your last edit. Cylinder intersects with the rest of the object which can't by solved by Boolean in this case. If using Boolean, do it on objects with not intersecting meshes or cut manually. $\endgroup$ – Mr Zak Dec 29 '17 at 10:57
0
$\begingroup$

As a workaround, you can try to switch the solver to the old Carve one. The new BMesh solver is usually the preferred solution, as it is way faster, but the Carve onve can handle more of these corner cases. This is what your mesh looks like if you switch the solver type (see the Solver field on the right):

Solver Change

Remember that you need to put the cutting object on a different layer than the source one, and turn off the visibility of the cutting layer, otherwise you always see both objects at the same time.

$\endgroup$
0
$\begingroup$

Interesting. It turned out that if I separated the extruding cylindrical 'sub-mesh' if you will, then everything works out fine. I suppose it has something to do with the fact that I inserted that object in Edit mode instead of Object mode.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.