1
$\begingroup$

Newbie to blender here, I've done quite a bit of searching through the rest of the forum for this answer but I'm sorry if it's already been asked.

I work in a medical office and we might possibly be 3d printing a prosthetic nose attachment. We have a patient missing some of her nose and I have a 3d scan of her face. I also have a 3d scan of someone else's nose I am trying to fit on the front of her face. (Pictured, I can't show much more for confidentiality reasons)

Nose

I've lined them up fairly well and I was thinking I'd use boolean difference to "carve" out from the nose attachment everything that was really on the patient's face. For some reason the modifier just isn't working at all. When I click, nothing happens. I've read around the forum's and suggestions such as solidifying the objects (they already have been) don't seem to work. The bulk of the other suggestions deal with making sure the objects are manifold. When I use shift-ctrl-alt-m to find non-manifold surfaces, nothing shows up.

The other thing I read was that overlapping parts can cause some issues for the boolean modifier... well, that one I don't know how to get around. Maybe you have some suggestions?

Edit: Update for you: both items are scaled the same. I removed all doubles, followed guidelines suggested by cegaton and made sure normals faced the same way.

They had been solidified but I noticed that the modifier WAS actually doing something, it was just drawing a faint line around the nose where it overlapped.. so I realized while the face was solid it just wasn't very thick. So I solidified it as much as blender would allow me (without turning the face into a giant ball) and tried again... Which resulted in this:

stack

My overlap threshold is set at 0.0002. That seemed to make it more noticable than when it was set at 0.000001.... but let me know if thats a huge mistake.

Or if there is an easy way to separate the part of the nose I want after it did draw a faint line.... I'm game.

$\endgroup$
  • $\begingroup$ Most likely your problem is caused by non manfiold geometry. For comprehensive post on booleans read: Boolean Modifier not working $\endgroup$ – cegaton Apr 19 '18 at 19:36
  • $\begingroup$ Your meshes may also be too complex, try reducing them to the smallest most essential parts only before the operation $\endgroup$ – Duarte Farrajota Ramos Apr 20 '18 at 0:01
0
$\begingroup$

Booleans are odd things and need certain things to be right before they work, one of the things that stops them working is Scale.

Make sure you have the scale of both objects set to $1,1,1$. by pressing Ctrl + A to Apply Scale (adjust geometry to match the scaled version and set scale to $1$.

Also try and make sure your models are fully closed (solid with no holes). Since your working with a scan of a face, try to add geometry on the back, or use the Solidify modifier with a large thickness, to turn it into a solid object.

I also find the Bool Tools addon helps me a lot as well.

Occasionally I have also used a work around of copying the Boolean objects and pasting them into a fresh scene and voila, it works! Not always a reason given, you can then paste them back to where they need to be.

$\endgroup$
  • $\begingroup$ Literally no idea why it finally worked, but bool tools did it. Carve boolean solver instead of bmesh. $\endgroup$ – Joe Crozier Apr 20 '18 at 15:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.