1
$\begingroup$

enter image description hereI am having a problem with my render layers. For clear illustration, I created a plane and a box. The box is partly beneath the plane. The plane is on my first render layer and the box on the second. Now when I render, the part of the box that is below the plane is shown in black.

I know that the black part of the box is below the plane, but is there a way to cut this part from the image or even exclude it from the rendering?

I hope someone can help me.

Marijn

enter image description here

$\endgroup$
3
  • $\begingroup$ What do your composition nodes look like? $\endgroup$ – Tsimp. Dim May 21 '17 at 9:57
  • $\begingroup$ hi, you should perhaps share some info (or images) of relevant node setuo/render settings... $\endgroup$ – m.ardito May 21 '17 at 10:39
  • $\begingroup$ I added the node setup. $\endgroup$ – Marijn Tulp May 22 '17 at 8:28
2
$\begingroup$
  • Option 01 - for Cube Render Layer mark Floor Render Layer as Mask Layer

enter image description here enter image description here

  • Option 02 - use Z-Combine node to merge them together

enter image description here enter image description here


Notes: It is good to understand what happened in 2.8x versions ...

  • Render Layers are almost the same concept
  • Layers are in 2.8 represented by Collections. Now you are not selecting Collections to be rendered, but you mark collections you want to participate only indirectly - objects are not rendered directly, only indirectly by their shadow or light bounce
  • Mask Layers are the same concept in therm of just activating collection in outliner

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.