1
$\begingroup$

Just a novice here.

I have a scene of a furnace with two separate smoke simulations. I have isolated one smoke simulation in it's own second layer (camera, sun lamp, mesh with smoke and smoke domain). I have managed to composite both together to create the image I want (2 x render layers going through an add node, into the composite node). However, they are part of a 150 frame animation. How do I do this so that I obtain all 150 frames without manually going through each.

I have tried running the animation normally with the composition option ticked in the post processing panel, but it just renders one of the 2 layers (does not seem to change anything).

I cannot simply render both layers simultaneously because the fire in layer one intersects with the smoke domain in layer 2 (which is much too big) and so I get a huge fire on top of the of the small fire I want.

I tried changing the reaction speed to 4, but the fire is still too much too big (4 is the maximum range I am allowed, from 0.01 to 4).

I tried rendering both animations, and then compositing the image sequences, but the smoke from layer 2 appears in the very front of the image, even when a another object is in front (in 3d-space).

Of note: I have the same camera and sun lamp in both layers

I hope that was clear enough. Thank you so much to anyone that takes the time to answer, great community!

$\endgroup$
  • $\begingroup$ "...it just renders one of the 2 layers." They both should be rendered (if they are overlayed in Compositor). Check that Pin button isn't enabled in Render Layers tab to the right from list of layers. $\endgroup$ – Mr Zak Mar 15 '16 at 0:05
0
$\begingroup$

Ok so I found out my problem. Totally my fault, as I misunderstood this passage from: https://www.blender.org/manual/render/post_process/layers.html


Scene (layer) The Scene Layers, showing which are currently visible and will be rendered. (render) Layer The Scene Layers which are associated with the active Render Layer. Objects in those Scene Layers will be rendered in that Render Layer. When an object is in the Scene Layers but not the Render Layer, it will still cast shadows and be visible in reflections, so it is still indirectly visible.


I had setup two render layers, one of which contained scene layer 1, and the other scene layer 2. I tried rendering by having only one scene layer visible. Here is where the confusing part is. When 2 scene layers are visible (or more) and I run a smoke simulation, it shows that my flow objects from scene one are pouring into my smoke domain from scene 2. However, if you render properly, even though the simulation shows up that way, the render still comes out right. I just got lost in the confusion but pulled myself out eventually.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.