1
$\begingroup$

I seem to have nothing but problems with compositing and Render Layers. :-\ Every tutorial I’ve followed so far on Blender Guru, I’ve been unable to replicate the process whether in 2.79 or 2.80. As part of a tutorial, I’ve added some lights in their own Collection, added another Render Layer and called it (Spot) Lights, disabled all the Collections I don’t want, unchecked the eye for everything I don’t want, and the other Layer has everything else in the scene enabled with the eye on. Rendering out my first scene/RenderLayer proceeds to render out the next RenderLayer containing the lights. However, for some weird reason, it renders out some of my other lights in the scene, along with the background and the floor. If I continue to follow the tutorial and set up the nodes the same, the end result is almost there, but my main building/object becomes semi-transparent.

enter image description here

How could I fix this? How can I prevent the second Layer from including those objects when they're not even enabled in that layer?

$\endgroup$
  • $\begingroup$ It is kind of hard to follow and understand your question. Could you add your .blend by uploading it to blend-exchange.giantcowfilms.com, edit the question and paste the link into it? That way it is easier to figure out whats wrong $\endgroup$ – WhatAMesh Jul 29 '19 at 19:30
  • $\begingroup$ Save file added. $\endgroup$ – DustyShinigami Jul 29 '19 at 19:41
0
$\begingroup$

One thing - disabling Eye icon in Outliner Editor hides object from viewport not from Rendering, for that you have to enable Render (Camera) icon in filtering.

Disableing these objects from rendering will affect both Layers. To fix it you have to place them into separate Collection (I called it "Scene"). Like that you can disable it for one layer and keep in others by switching checkbox of collection.

enter image description here enter image description here

Second thing - To add additional Lights with Glare in compositor I would use rather enable Film > Transparency and in compositor use Alpha socket as input. Alpha because even you disable whole Scene collection you still use world light that will affect compositing. Like that you can also save one Mix node from tree to get same result.

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.