4
$\begingroup$

I have made a conversion of a mesh for the Dragon Age 2 video-game, and though the model animates properly in-game, and the weights are fine, I can't get rid of a weird problem with the neck. enter image description here

As you can see in the picture, there's some sort of gap, as if the head was floating in a misplaced position. The armature of the model is a completely different file which I didn't touch at all. There's not currently any Blender plugin to export edited armatures for Dragon Age 2, so I have to do with the original one (which otherwise works perfectly). I tried setting the armature as parent for all the mesh chunks (as was the case with the original mesh) but still nothing. I also set the body as parent for the head without results. What am I doing wrong? Here's the .blend file, in case it helps (it was made with Blender 2.49, because the import/export plugins don't work in newer versions):

http://www.filedropper.com/scenefixed5

$\endgroup$
1
$\begingroup$

If you join the head and the torso meshes, and check the weights of Vertex Group Chest2 you can see thats the weighs are different between the separate parts. That is the reason why during the animation the meshes are separating.

The solution is to equalize the weights between the meshes, I would suggest using blur brush in weight paint mode.

enter image description here

$\endgroup$
  • $\begingroup$ I tried that but it didn't work. It's as if the mesh ignored any weight paint. It looks the same no matter the color of the neck vertex. $\endgroup$ – Iredc Dec 21 '16 at 16:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.