0
$\begingroup$

I have a tragicomic problem, which arose after I joined the armature for eye animation with the armature for the head animation by Ctrl+J. Right after that the head becomes very small rotates 90 degrees and jumps into one of the eyes:)If I hide the head mesh, then the eyes become very big, move above head and overlap . I managed to partially solve the problem by unparenting meshes from the armatures, then joining the armatures by ctrl+j and then parenting back the eyes. It all worked OK, but I cant parent back the head, as it get deformed in a very strange way:)Any ideas how to solve this issue would be appreciated (beyond and above:))))))

$\endgroup$
  • $\begingroup$ Have you applied all transforms before parenting? $\endgroup$ – Tiles Jan 21 '18 at 8:30
  • $\begingroup$ yes,I have applied them, but nothing changed. With the head I applied p. with automatic weights, it gets deformed severely:) I tried to apply p.with envelope groups, the head is no longer deformed, but not affected by the bones either:) $\endgroup$ – Kas Jan 21 '18 at 8:57
  • $\begingroup$ Hm, hard to say. Can you reproduce the problem? Can you attach an example file? $\endgroup$ – Tiles Jan 21 '18 at 9:07
  • $\begingroup$ Thanks for taking your time to look into this issue, Tiles:) $\endgroup$ – Kas Jan 21 '18 at 9:20
  • $\begingroup$ drive.google.com/file/d/1n48Z8paexrqBaNxJR28HsVk0NG-pu4GK/… $\endgroup$ – Kas Jan 21 '18 at 9:45
0
$\begingroup$

I had a look at the file. This is caused by your shapekeys that uses vertex groups. Weighting is also assigning vertex groups. And that's what is conflicting here when you skin your headmesh. When i remove the vertex groups for the shapekeys before skinning then all works well.

So, first skin the head mesh, then create the shape keys for it.

$\endgroup$
  • $\begingroup$ Thank you for your time and attention:) I thought about shape keys, that's why I created totally new files with simplistic turtle-like meshes, just head and the eyes:) no shape keys, nothing at all:) Maybe I have activated something which shouldn't be activated, maybe in the user settings... I don't know:) Will upload the experimental turtle file in a minute:) $\endgroup$ – Kas Jan 22 '18 at 10:26
  • $\begingroup$ drive.google.com/file/d/1KuW6jI8r5i3UB4IhaazF8RJc9AgpU9QC/… $\endgroup$ – Kas Jan 22 '18 at 10:33
  • $\begingroup$ I have just tried deleting the shape keys, It didn't work for me, again the eyes become bigger than head and jump into each other just like in the turtle file:) This is giving me grey hairs:) Could you please have a look at that turtle file?:) $\endgroup$ – Kas Jan 22 '18 at 10:58
  • $\begingroup$ You need to remove the vertex groups, not just the shape keys. $\endgroup$ – Tiles Jan 22 '18 at 13:04
  • $\begingroup$ it didn't work for me. I have removed them too, before writing the previous comment. I have come across a similar problem here, the solution was to slightly bend the armature before parenting (a bit different case), but I tried bending the head armature, and the eyes haven't become big and jumped into each other, but remained their original size and jumped opposite to each other and sit on the ends of the biggest bone:) $\endgroup$ – Kas Jan 22 '18 at 14:36
0
$\begingroup$

After joining armatures bones matrices are rewritten relative to new armature and every child object or paint weighted object goes to its local coordinates. So the cleanest way is that first you remove any parenting or weight paint from joining armature and after joining redo skinning and parenting.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.