7
$\begingroup$

I am making an animation(in cycles render) where object is converting from diffuse to transparent(with 0.9 value on mix shader). I am using branched path tracing (with square samples) Settings Screenshot Below is the rendering sample. All rendering is good except for the transparent part.Rendering Sample

I am using Diffuse material with Transparent material(mix shader value changes from 0 to 0.9 in animation)

Below is the shader window. enter image description here

Its taking 2mins per frame. How to make it look perfect in this render time?

$\endgroup$
  • $\begingroup$ Do you actually have any volumetrics in there? You shouldn't expect a render time of 2 mins if the volume bounces are set to 2 (provided you have volumetrics). $\endgroup$ – JakeD Nov 11 '16 at 20:20
  • $\begingroup$ No I don't have any volumetrics in the scene. But my scene is a little big. Its just a part of it. $\endgroup$ – Prasoon Nov 12 '16 at 4:44
7
$\begingroup$

Try enabling Transparent Shadows in Properties > Render > Light Paths:

enter image description here

This setting enables an optimization which greatly reduces noise in shadows cast by partially transparent objects, at the cost of some speed.

Here's a comparison rendered with sampling settings identical to yours (except for the shadow setting of course).

With Shadows disabled (1:59):

enter image description here

With Shadows enabled (2:11):

enter image description here

Note that you can also disable this option per-material via the Transparent Shadows setting in Properties > Materials > Settings

$\endgroup$
  • $\begingroup$ If I enable shadows, my display driver is crashing. $\endgroup$ – Prasoon Nov 12 '16 at 4:34
  • 2
    $\begingroup$ @Prasoon Then solve that problem. Your "display driver...crashing" is not a reason to reject the actual Blender solution. If this is what fixes it (and by the number of votes it has it looks like it probably does), then just look into the driver problem so you can use it. $\endgroup$ – JakeD Nov 12 '16 at 13:03
  • $\begingroup$ I did two things & the problem is now solved without enabling shadows. $\endgroup$ – Prasoon Nov 12 '16 at 16:12
  • $\begingroup$ @Prasoon I must admit, cycles causing a driver crash is not something I've experienced before ;) Are you using GPU rendering? Does this occur with a nightly build of blender? If so, I'd consider submitting a bug report $\endgroup$ – gandalf3 Nov 13 '16 at 0:16
  • $\begingroup$ @gandalf3 Ya I am using GPU rendering with Blender version 2.77a.But I not sure its a blender issue or I am using wrong settings to render. As the *.blend file size for this animation is 300MB. I think size may be the issue. $\endgroup$ – Prasoon Nov 13 '16 at 6:03
0
$\begingroup$

Firstly I removed checkmarks except for camera in object properties.enter image description here

Next I removed the tick mark from Transparent shadows in material properties. enter image description here

Now my final rendering is coming like below. Rendering time is little bit more but that's OK. enter image description here

Thanks for the help @gandalf3

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.