1
$\begingroup$

I reinstalled Blender and I'm still unable to see AA sample when I selected Branch Path Tracing.

enter image description here

Also, when I tried rendering it with GPU Compute, it comes out blank. I really need to figure out how to get the AA samples as I tried to render the animation on CPU 5000 render samples and looks the same (Which is blurry).I also tried rendering this animation on my Windows laptop and it took 7 hours to just render a 2 seconds animation which looks blurry.

Here's the link to my Blender file:

enter image description here

$\endgroup$
  • $\begingroup$ are you using an official build and recent version of blender? Is rendering with the default path tracer causing you issues that you had to you the branched path tracer? $\endgroup$ – user2816 May 28 '16 at 8:40
  • $\begingroup$ about the GPU error,this could be caused when a scene is too complex to render with your graphic card.to test see how much ram it takes for one frame to render on CPU and see if that value fits in your GPU' VRAM. $\endgroup$ – user2816 May 28 '16 at 8:45
  • $\begingroup$ I downloaded the newest version of Blender today so surely is the most recent. No, Path tracing is not causing any issues, I deliberately selected branched path tracking so I could reduce the blurriness. For my windows laptop, it is taking unbelievable long 7 hours for 8 frames that it is so blurry is totally crazy. For other youtube videos i seen it only took them no more than half an hour to render. I also increased the sample render to 800 which was recommended by many people to reduce the blurriness, i guess that did not help. Please help, this is my school assignment and it is due soon. $\endgroup$ – Jeff Teoh May 28 '16 at 9:34
  • $\begingroup$ My windows laptop have: NVIDIA GT 520M , 8GB of ram , 64-bit operating system. $\endgroup$ – Jeff Teoh May 28 '16 at 9:59
  • $\begingroup$ I'm afraid i don't have a solution, you could perhaps separate the objects into multiple render layers and composite them later on. this may allow you to render with the GPU and not fail. you could also speed up the rendering by only calculating what the camera sees . sadly those are minor speed ups and probably are not worth the trouble. hopefully someone else can help you. $\endgroup$ – user2816 May 28 '16 at 10:18
1
$\begingroup$

I cannot help with your GPU because I don't have access to your computer. However, I was able to figure out the bluriness.

Problem

In your scene, one of the first things I noticed was that it was inside an enclosed space. Bluriness in enclosed spaces can often be caused by low lighting.

Solution

I selected the area lamp near the top of the cabin and turned up the Emission Strength to 1000 from 300. I also turned the Max Bounces: to 1024.

I also optimized the .blend file.

I made some adjustments in the Render tab of the Properties panel, namely that I set the Max: and Min: Light Path Bounces to 0 (for faster rendering). I also turned the Filter Glossy: value to 0.7. Additionally, I changed the resolution to just 1920x1080 (1080p; you had it set to 4k which really won't make any difference except causing the rendering to take 4 times as long). Furthermore, I turned the Sampling > Settings: > Clamp Indirect: value to 3.00. I turned the AA render samples to 100. Lastly, I optimized the Tile Size for CPU rendering (Properties panel > Render Tab > Performance Drop Down Menu > Tiles:). If you want it to be optimized for GPU rendering, change each (x/y) from 16 to 256.

On my 8-year-old mac with CPU and not all the image textures, one frame (probably) took a bit under an hour (I didn't wait for it to finish). On my Nvidia 970 4GB STRIX, one frame took just 54 seconds and looked like this:

enter image description here

Final Notes

Here is the fixed up .blend file:

I don't generally offer this (haven't before), but if you can get me a .blend file with all the images included, I will render it for you. 90 frames x 1 min each = about 90 min. --A fellow Blender-using student.

$\endgroup$
  • $\begingroup$ The images were basically from this website: github.com/TheDuckCow/MCprep/releases once you download it comes as an addon for blender. You import the addon and select an object in the secene click mcprep mineways and prep materials and everything should be in coloured. $\endgroup$ – Jeff Teoh May 28 '16 at 13:12
  • $\begingroup$ Can you not do what I suggested in the comments? I may be able to follow the link, but I'm pressed for time today. $\endgroup$ – Shady Puck May 28 '16 at 13:13
  • $\begingroup$ Oh yes, I want to thank you so much for helping me!. I was wondering whether I could have your email or something so I keep in touch with you. $\endgroup$ – Jeff Teoh May 28 '16 at 13:25
  • $\begingroup$ I'll always answer on the stack exchange app, but there is a thing called chat on BSE. Maybe I'll look into that. P.s. If my answer helped, please consider accepting it (the check mark) and the one on your other question. I will try to follow that link later today to render. $\endgroup$ – Shady Puck May 28 '16 at 13:38
  • $\begingroup$ Ok! I want to thank you again for all your help! $\endgroup$ – Jeff Teoh May 28 '16 at 13:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.