8
$\begingroup$

I have 2 objects that have been fractured, but for some reason I can't apply keyframes. I tried testing animating a cube to see if there were larger problems with settings but that worked fine. Could anyone shed some light on why this might be happening?

Thanks

Here's a screenshot:

enter image description here

Here's the .blend:

$\endgroup$
  • $\begingroup$ Perhaps try parenting each each fragment to a single empty (Therefore the empty controls the whole object), then animating the empty, and just before the objects collide, animate the fragments parenting so that they are in control of themselves just before collision. Does that make sense? $\endgroup$ – christai Feb 24 '17 at 9:00
  • $\begingroup$ Did you get this sorted out? $\endgroup$ – Edgel3D Jun 17 at 2:18
  • $\begingroup$ I can't remember since it was years ago lol, but I think now I would simply use the Fracture Modifier...back then I was using cell fracture $\endgroup$ – lakerice Jun 19 at 14:22
  • $\begingroup$ Actually I'd somehow got into 'Unanswered Questions' but asked anyway. :) I tried using Cell fracture in some jobs but always came up against the animation wanting to start at frame 1 so I ended up adopting the Explode modifier and adding my own 3D shrapnel from one or more additional emitters. It eliminated the need to determine the fractures beforehand and yet still appear to be breaking up into recognisable components, just by designing those as emitter objects. Works well for me. Cheers... $\endgroup$ – Edgel3D Jun 21 at 1:59
0
$\begingroup$

Check the "Animated" box in your physics settings. As it's name states, it will allow you to animate the objects with keyframes.

$\endgroup$
  • 1
    $\begingroup$ Hm it seems to work for individual fragments but not the whole object when I copy from active... $\endgroup$ – lakerice Jul 20 '16 at 2:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.