I'm using geometry nodes to make a building and I've tried animating the number of floors the building has.

Every frame where a new floor is introduced, the building looks really weird and in the next frame it's perfectly fine. Check this:

enter image description here frame 50 enter image description here frame 51

enter image description here frame 52

I have some composition options (bloom and AO), but removing them didn't help. I also have bloom, AO and motion blur enabled in my render options, but disabling that didn't help either.

In the viewport, the building looks fine in that certain frame:

enter image description here

Does anyone know why my renders in Eevee get kinda transparent in certain frames? Also, when I try to render that specific frame with Cycles, it works fine. Does anyone know why is this happening?

  • $\begingroup$ can you please provide your blend file so we can check it out? $\endgroup$
    – Chris
    Commented Jul 3, 2021 at 11:41
  • $\begingroup$ Of course, no problem. It's a bit messy, though! :D easyupload.io/64m2c6 $\endgroup$
    – ShockwaVe
    Commented Jul 3, 2021 at 11:46
  • $\begingroup$ Thanks for your blend file. I didn't even know that you can have two group inputs...;) i tried different things...but nothing helped :( i have no idea...sorry. $\endgroup$
    – Chris
    Commented Jul 3, 2021 at 12:39
  • $\begingroup$ Thanks for trying, I appreciate it! $\endgroup$
    – ShockwaVe
    Commented Jul 3, 2021 at 13:26
  • $\begingroup$ just for info to others: I could clearly reproduce the error. $\endgroup$
    – Chris
    Commented Jul 3, 2021 at 13:37

1 Answer 1


The glitch is caused by the Motion Blur setting in the Eevee render settings. Turn it off and the animation will render properly.

It looks like Motion Blur can't handle the creation of additional geometry by the Geometry Nodes. The error always occurs exactly at the frames where the next floor is built. It seems that Blender tries to morph two frames to simulate motion blur, but the "motion" (actually building the next floor) is too hard for a smooth morph transition within two frames. The frames differ too much. The result is then this semi-transparent overlapping image of two frames.

Motion Blur on:
blur on

Motion Blur off:
blur off

  • $\begingroup$ Oh, just noticed that you wrote you already tried to turn off motion blur without success. It works for me when I turn it off. Added images of the render. (Blender 2.93) - $\endgroup$
    – Blunder
    Commented Jul 3, 2021 at 18:16
  • $\begingroup$ That's it, I must've done something wrong or maybe it didn't render properly for me the first time. It's working now as expected when I turn the motion blur off! Thanks a lot, it was driving me nuts! $\endgroup$
    – ShockwaVe
    Commented Jul 3, 2021 at 19:28
  • $\begingroup$ @ShockwaVe: Please check the checkmark left to Blunder's answer so that other people know that it is the right answer. Thank you. $\endgroup$
    – Chris
    Commented Jul 4, 2021 at 8:02
  • $\begingroup$ My bad, thanks for reminding me! $\endgroup$
    – ShockwaVe
    Commented Jul 4, 2021 at 9:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .