1
$\begingroup$

I’m just starting animating soft body objects, have hit something and I don’t understand why is happening.

I have my model in T pose and the first 20 frames are to get an arms by the side pose.

I committed all bones at the beginning of the animation and have moved the hand IK around until it’s where I want it and also the elbow thingies to make it more fluent. That works fine.

Now I want to (for this demos purposes) lift the leg up and only move the leg from this point.

I select all and commit the keyframes at frame 20. I now select the foot IK and move it in the Z direction at frame 28.

Frame 20 to 28 work fine but 1 to 20 have a keyframe now that Blender must have added that causes the foot IK to lift and drop. The first frame and frame 20 are identical. Something has been added in between.

The only things I have changed is the IK hands and elbow thingies (1 to 20) and the IK left foot (after frame 20 at frame 28)

Why is this happening?

I don’t want the foot to start moving until after frame 20 and I thought that by committing all the bones keyframes at 20 would have enabled this.

Blender file and video in google folder link.

https://drive.google.com/drive/folders/19Tcm8kIcrqiBJ6VHtkU4LJsA78_IobVr?usp=share_link

Thanks.

Andy

$\endgroup$
0

1 Answer 1

1
$\begingroup$

As you can see in the graph editor, you are using Automatic bezier handle type, which tries to interpolate smoothly between the 3 keyframes available, making the foot to move between frame 1 and 20 also, even if there is no keyframe in that region and the two keyframes at its boundaries share the same value.

To solve, select all the needed keyframes, press right click > Handle Type > Auto Clamped (shorcut V).

This will result in having the foot still between frame 1 and 20, and correctly showing a line between its loc keyframes, stating that no move will happen in that region.

enter image description here

$\endgroup$
1
  • $\begingroup$ HI, thank you for taking the time to explain. Andy. $\endgroup$
    – AndyC
    Commented Apr 10 at 14:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .