3
$\begingroup$

I am having problems with the Mist pass. I have search other questions but didn't find the answer.

As you can see, I got an ocean (left) and a "river" (right). Don`t mind about the river disappearing towards the right, I need that way but doesn´t affect my problem (but I wanted to keep the settings as I have in the big project).

When trying to get the Mist pass, both objects are semitransparent, as you can see here: mist

Also the Z pass gets crazy: enter image description here

I think is because they both have glass and transparent material, and also volume absorption.

The sun is 0.8 in size and 5 Max bounces.

So, the question is: How can I get the Mist pass "skip" the transparency settings of both objects?

Thanks in advance!

$\endgroup$

2 Answers 2

2
$\begingroup$

Create a new render layer in which the material is overriden by some material that has no transparency, and enable mist for that render layer. Then use the mist pass from that layer to combine over the other layers.

enter image description here

(click on the image to enlarge)

$\endgroup$
1
  • 1
    $\begingroup$ Thank you cegaton! Perfectly resolved and in an easy way, without having to do much extra work. Maybe in Blender's updates they will make it even more easier! $\endgroup$
    – user27570
    Jul 16, 2016 at 18:18
1
$\begingroup$

As long as it doesn't affect your other render passes, you can go to the View Layers Tab > Passes > Data set the Alpha Threshold to zero.

This will effectively make the Depth Pass ignore the alpha of all objects that are transparent or translucent to any degree. It will treat them as solid objects.

This option is only available in Cycles, AFAIK EEVEE already ignores transparency for Depth passes.

enter image description here

$\endgroup$

You must log in to answer this question.