0
$\begingroup$

Blender's texture painting is making me crazy right now.
I'm working with cycles and I've defined two different images in the node editor. One for each of my eyes in the own node editor.

Still... I can't paint on the different images. If I go into texture painting, I can only choose a picture in the slots window, and it displays it on both of the eyes! They shouldn't have any connection at all - different objects, different node - still I can't work on them separately.

I'm not used to this new Slots settings, and guess something is working wrong there. But I don't really know how to fix the problem.

$\endgroup$
  • $\begingroup$ did you assign different materials to each one of the eyes? $\endgroup$ – cegaton Apr 30 '16 at 14:36
  • $\begingroup$ yes, different materials are choosen $\endgroup$ – Nomiki Apr 30 '16 at 21:29
  • $\begingroup$ Things getting more weird - i managed to render the other image and get 2 differen eyes. In Object mode its also displayed that way! But in texture paint mode both objects share the same image ...and i cant paint one without destroying the other. $\endgroup$ – Nomiki Apr 30 '16 at 21:38
  • $\begingroup$ I got NO clue why but it seems to depend on which Mesh is selected in the object mode before turning into Texture mode. To make it more confusing I need to select the right eye and go into texture mode afterwards if I want to paint the left one. At least blender crashed now, maybe the restart will help -.- $\endgroup$ – Nomiki Apr 30 '16 at 21:42
  • $\begingroup$ Can you please edit your question and add more information, images or your settings or upload your file so maybe someone can help you? $\endgroup$ – cegaton Apr 30 '16 at 22:17
1
$\begingroup$

You were close. Instead of changing painting mode, you need to specify on what image you want to paint, selecting the canvas image in slots panel.

Canvas

It's handy if you want to clone to specific image from multiple different UVs and images.

$\endgroup$
0
$\begingroup$

I guess I kinda solved my problem. I set the painting mode in the "Slots" tab from "image" to "material"... not sure what that's about, because I got an image as "Material" but at least it works now.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.