15
$\begingroup$

Using the Blender Render, if you have no lamps, the objects are black. With Cycles Render, even without any lamps, there is a small amount of light.

Here is a render of the same yellow monkey without any lamps present using the two render engines:

Comparison of renders of the same scene using Blender Internal and Cycles

Where does this light come from? Can you turn it off?

$\endgroup$
  • $\begingroup$ Your profile mentions what is probably [videos] $\endgroup$ – atomicbezierslinger Sep 14 '17 at 3:26
16
$\begingroup$

In cycles the World emits light. You can turn this off by setting the world color to black, or setting the Strength to 0 in Properties > World:

enter image description here

If you still want the background to appear as a color besides black, you can make the world emit light only for the camera by mixing two Background shaders based on the Is Camera Ray output of the Light Path node:

enter image description here

Result:

enter image description here

$\endgroup$
  • $\begingroup$ Or you can also set "film" to transparent in the render panel, and add a color in the compositor with "RGB" and "Alpha Over" nodes ;) $\endgroup$ – Polosson Dec 19 '13 at 13:46
  • $\begingroup$ @Polosson You can, but I think this way is faster if you are not doing any compositing already. $\endgroup$ – gandalf3 Dec 19 '13 at 17:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.