4
$\begingroup$

enter image description here

I am having some issues when rendering an image, my rendering screen is turning into grey even when making a full render. What am I doing wrong?

$\endgroup$
6
$\begingroup$

You have the focus of the camera set to 0 and are using a lens aperture of 1.0. Basically your scene is so out of focus that you only see gray. Change the distance value to the actual distance form the camera to your object, and maybe try a higher number for the f-stop.

To find where your camera is focusing you can enable display->Limits. If you move the focus you'll see a cross mark that indicates where the focus point is:

enter image description here

A trick you can do is use an empty. Move the empty to the place you want the camera to focus on and select the empty (or any other object as the focus target).

enter image description here

$\endgroup$
1
$\begingroup$

Also check the Clipping settings for the Camera..(what you want to see should fit between the Start and End values).

$\endgroup$
  • $\begingroup$ This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. - From Review $\endgroup$ – VRM Mar 7 '17 at 21:57
  • $\begingroup$ You say that, but this exactly was why my Blender image was rendering uniform grey. As soon as I changed clipping settings all was well. So I added it as a comment because all the above did NOT fix my issue, and this did. And I'm sure at some point in the future I'll forget about the Clipping settings, and google, and land here.. $\endgroup$ – user1692094 Mar 9 '17 at 8:57
  • $\begingroup$ This is a completely different issue though. Also it is extremely poor quality. You really should have just posted a comment saying "A similar issue I found is caused by having camera clipping set improperly" or something similar. $\endgroup$ – VRM Mar 9 '17 at 16:06
  • $\begingroup$ This answer does not apply for the specific question. There are a lot of causes for grey, blank and transparent rendered images. Some of them listed here: blender.stackexchange.com/questions/53632/… $\endgroup$ – cegaton Mar 9 '17 at 18:35
  • 1
    $\begingroup$ All I know is I got a grey image, tried a few things, then googled my question and landed here. Given answers did not fix it, but something else did. Pretty sure it's then common courtesy to add the thing that fixed it for me so others don't have to spend the extra time googling. The given answers did prompt me to look a little closer at the camera settings. For more experienced Blender users this might be an obvious thing - but more experienced Blender users probably don't land here with this issue. QED I think it belongs here even if it's not completely relevant to OP's issue). $\endgroup$ – user1692094 Mar 10 '17 at 18:16
1
$\begingroup$

I was having a similar problem and well the reason was rather funny. In my ViewPort, I had my roof hidden, but it was flagged for rendering. So trying to figure out why I couldn't see my couch ... I zoomed the camera further back to check and that's when I realized my error.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.