3
$\begingroup$

I have this mesh in Blender 4.1 and possibly more types of meshes with this type of pixelic art, but I can't figure out how I can smooth it out and turn it into a curve object.

enter image description here

Don't worry about the square faces inside, this is just the initial mesh which I put a Limited Dissolve to remove all the interior vertices so we are left with the edge outline.

enter image description here

I tried Subdivision modifier to no avail

enter image description here

I also tried the Smooth Corrective modifier, but I can't find the right settings to make it smooth. It gets too thin if I set repeat to 20-30. The Smooth Laplacian didn't do anything.

enter image description here

How do I smooth it out and turn it into Curve object? Perhaps I need to use geometry nodes?

$\endgroup$

1 Answer 1

5
$\begingroup$

You can try a CtrlV > Smooth Vertices in Edit mode, increase the Repeat value:

enter image description here

Also press X > Limited Dissolve to simplify the mesh:

enter image description here

Convert to curve then convert from Poly to Bezier Curve:

enter image description here

Then press V > Automatic to round the vertices:

enter image description here

Result, you can still tweak the vertices so that it sticks more to the shape you want, if it's too different from what you wanted, I guess the solution is to redo the shape from scratch with a curve, taking the original image as reference:

enter image description here

$\endgroup$
6
  • $\begingroup$ thank you so much! $\endgroup$
    – Megan Love
    Apr 23 at 15:47
  • $\begingroup$ oh yeah i see notice it doesn't work perfectly, the eye of the dog breaks. this will be a problem since I want to automate this so I can't go in and do manual fixes. $\endgroup$
    – Megan Love
    Apr 23 at 15:54
  • $\begingroup$ Yes you can still correct in Edit mode afterwards $\endgroup$
    – moonboots
    Apr 23 at 15:57
  • $\begingroup$ yes but unfortunately I need to automate this with python later so I can't do manual adjustments. But maybe it is just a setting in the "Limited Dissolve" that can prevent the weird edge generation. $\endgroup$
    – Megan Love
    Apr 23 at 15:58
  • $\begingroup$ Sure, try a lower angle value when you dissolve $\endgroup$
    – moonboots
    Apr 23 at 16:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .