I work in millimeter units. Therefore, all architectural work is carried out in millimeters. But I noticed that the blender is designed for meters. All Gizmo objects are always very large.

I searched the answers and Google and the Blender-menu but could not find the answer.

How can I reduce the apparent (visibility in viewport) size of the Spot Light Sources?

enter image description here enter image description here enter image description here

I added an update without too much detail: how to reduce this distance in the viewport? how to reduce this distance in the viewport?

  • $\begingroup$ Hi ! First version of my answer was explaining units-related settings, but not the Spot Lights specifically — I've updated the answer to cover this thing too. $\endgroup$
    – Yaroslav
    Commented Feb 12 at 18:12
  • $\begingroup$ thank you. I am update post too I added a spot to the second floor of my cafe, and as you can see its visual display extends to the basement. if I add 10 spots on 2nd floor. it will create visual chaos on the first floor and it will simply be difficult for me to work visually. I'd like to just reduce the size of the gizmo. $\endgroup$ Commented Feb 12 at 21:27

2 Answers 2


You can simply select your spot lights and scale them up or down (object mode scaling.) A light's scale has absolutely no effect on the way that the light renders, not even on its "radius" property, but it affects the viewport display of the light. This is sort of weird on Blender's part-- it's one of the few ways where you can't just scale an entire scene up or down, the lights won't be consistent with the scale-- but in your case, it's convenient.

If you'd like to do this with all of your lights very quickly, and you don't have any area lights, you can select grouped->type (with light selected, shift-g in 3D viewport for me), change your pivot point to individual origins, and scale.

The only kind of light that is affected by scaling is an area light, so if you have any of those, you'll have to be careful not to scale those-- they'll get selected with select grouped by type above.

There are other useful techniques for managing the display of objects like this. I usually work with two 3D viewports open, one with overlays and gizmos disabled, so that I can see the controls I need to work with in one view without them interfering with the final product that I see in the other view (this is usually for dealing with armatures, but I can easily end up with a scene riddled with empties.) And it can often be useful to create collections of certain objects-- say, all spot lights-- so that the visibility of these collections can be toggled rapidly.

enter image description here

Showing scaled and unscaled spotlights, two viewports, sidebar collection visibility panel.

  • $\begingroup$ Thanks. it works $\endgroup$ Commented Feb 13 at 18:13
  • $\begingroup$ By the way, I just noticed that if you scale only along by Z axis, then the spot light still changes its characteristics. its angle changes. although the Beam Shape parameter remains unchanged. $\endgroup$ Commented Feb 13 at 19:08
  • $\begingroup$ Scaling non-uniformly-- like only along Z-- will scale the overlay displayed, but it doesn't actually effect the render. This is kind of dangerous, because the angle the overlay displays is then a lie: it might look to be wider or more narrow, but it's not representing the actual angle of the spot, which is measured in world space. $\endgroup$
    – Nathan
    Commented Feb 13 at 19:44

Three things:

1) You always can switch scene units to millimeters on the right side panel :

enter image description here

2) You can always select an object — then press N to see it's options — then set the EXACT size of the object.


enter image description here

*Press N again to hide option bar.

3) And last but not least: you can set millimeters as your DEFAULT units.

To do so:

  1. Create new file.

  2. Set millimeters as units (the way it was mentioned before)

  3. Set this file (with all settings) as a "Startup File" – THIS WAY :

enter image description here


After those settings done : For Spot Lights just change the radius and size.


enter image description here

Voila! :-)

  • $\begingroup$ I know everything you described at the beginningб thank you. I just mentioned that all the Gizmos in the blender are huge when you work in millimeters. this is weird. It seems that Blender was only tested on objects the size of a car or larger. but as for spot light. are you sure that this is version 4.0 and that you selected the render cycles engine? because I don’t see such parameters in myself. Radius - I don't have that. But I can’t change the size parameter because... This already is responsible for the physical behavior of the light source. $\endgroup$ Commented Feb 12 at 21:19
  • $\begingroup$ I wrote about Visual display in viewport. This is what confuses me. look at the screenshot. how huge they are, they just filled the entire screen and I can’t work; they’re a visual mess. My light sources hang on the first floor but penetrate the floor up to the 2nd floor down. imagine if I do lighting on the second floor. All these light sources will fall through the floor onto the first floor and will disturb me. $\endgroup$ Commented Feb 12 at 21:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .