0
$\begingroup$

I was making a tunnel model for animation, but somewhere I may have done something wrong and now the objects in the viewport are displaying with the background and foreground flipped. The objects which should be hidden from view are visible and the foreground objects are hidden

From "background" I do not mean background images but objectsenter image description here

$\endgroup$
  • $\begingroup$ hey, welcome to the community. Please add screenshots so we can better understand your situation. $\endgroup$ – J.Doe Sep 3 at 21:50
  • $\begingroup$ I've added a screenshot.... $\endgroup$ – Zay Sep 4 at 8:15
0
$\begingroup$

Select the object in question, go Edit mode, flip normals and leave Edit mode. Check "Clip start" and "Clip end" of the View port camera (which not visible as an object...it is simply "there" :) ) which settings can be found on the right side pane und View->View top most second and third entry.

$\endgroup$
  • $\begingroup$ Got it, it was the clipping. $\endgroup$ – Zay Sep 5 at 5:56
  • $\begingroup$ In viewport rendering, I can't see the objects even with the lights present, they're all shown as transparent (I've set the background as transparent), that doesn't seem to be related to clipping. What could be the issue? $\endgroup$ – Zay Sep 5 at 6:05
  • $\begingroup$ would you mind to post your file or the relevant part of it? $\endgroup$ – user60781 Sep 5 at 6:31
  • $\begingroup$ It's kind of happening in all of the objects. However, at the moment it seems it's not an issue anymore, if I come across it again I will reach out (or maybe play around with clipping if it's that). $\endgroup$ – Zay Sep 5 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.