0
$\begingroup$

Blend file

I rerendered some frames I was missing, when they were done rendering I realized my object was not in them. In my viewport, sure enough, the objects were all gone after frame 582. As I kept trying to fix it, the objects are now completely gone from the whole timeline. I tried turning off culling, that didn't fix it. It's not clipping. I created a duplicate of the scene and the problem remained. All of my objects are enabled in their collections. I'm really at a loss here, do I have to redo my scene?

The Smoke In The Center Is Part Of The Scene In Question

The Smoke In The Center Is Part Of The Scene In Question

Here is what my scene has become (The smoke collection is meant to be enabled, it doesn't appear when it is enabled)

Here is what my scene has become

Fixed and updated screenshot showing smoke enabled

Fixed and updated screenshot showing smoke enabled

Update: After another reboot, the smoke/fire is back, but the shuttle ship and character model are still not there. But smoke/fire is still not visible in camera.

Update: After another reboot, the smoke/fire is back, but the shuttle ship and character model are still not there. But smoke/fire is still not visible in camera.

Issue still on my end

$\endgroup$
8
  • $\begingroup$ Hello and welcome. Instead of having users go through links and external sites please use the builtin tools to embed images in your post. See How to upload an image to a post? or GIF $\endgroup$ Oct 11, 2023 at 20:49
  • $\begingroup$ In the second screenshot I see an object disabled in viewport called "WaterTower.005" and disabled collections, "Abandoned City", "Smoke, Fire, Cloud" - the names sound like things visible in the first screenshot. If you disable the collections it is totally normal that they disappear. $\endgroup$ Oct 11, 2023 at 20:59
  • $\begingroup$ @Gordon Brinkmann : The city is part of another render layer, water tower is meant to be disabled, it isn't in this part of the scene. The smoke was meant to be enabled, that's my bad. Turned on it's the same. $\endgroup$ Oct 11, 2023 at 21:01
  • 1
    $\begingroup$ Have you rebooted your computer since then? Just to be clear: the objects in the first picture are the ones that are unhidden, and their parent collections are unhidden and enabled as well in the second and third pictures? We are supposed to see the same ground, smoke, debris and buildings, and they all seem correctly arranged in the outliner? If so, the next culprit could be your camera, is it at the right place in those frames? Does it have the right near/far clipping distances for what you need it to see? $\endgroup$
    – Lauloque
    Oct 11, 2023 at 23:18
  • $\begingroup$ @L0Lock : I have rebooted, yes. It even saved with everything missing. The only object in this render layer are a ship, character and a baked 2046 sample smoke/fire simulation. I wish I could upload the blend for everyone to look at but it's a massive file. It's a 30 second long oner. When I try selecting one of my objects in the the outlined and moving my view to active, it just snaps to my world origin and nothing is there. $\endgroup$ Oct 11, 2023 at 23:55

1 Answer 1

1
$\begingroup$

All your scene objects are contained within this cube that I added, it is 1476' wide and 1235' high:

scene

And here you see the cube in relation to the camera you are using, it is at X = -37129' and Z = 22889'! Apart from being very, very far away from the whole scene (which might be intended), it is also facing in the opposite direction.

camera distance

I'm not going to fix this for you since I have no idea if this is supposed to be at this large scale and what you want the animation to be... this is just to let you know why there are no objects visible in the camera view.

//EDIT: You mention the shuttle and "Me" not being visible after frame 582. As I explained above, your camera is way off, but maybe I have to make it more clear with images.

This is on frame #582, the camera is behind the shuttle, the shuttle is visible in front of it and also if you would switch the 3D Viewport to Rendered view:

shuttle in view

Now if you go just one step further to frame #583, I can zoom out a little to show you where the camera is and where the shuttle. It is way below the camera, so of course it will not be visible in the render:

shuttle dropping down from view

Go even one step further to #584 and the camera is already so far off that it's impossible to ever get the shuttle into view, here is a short step by step view from the side what's happening from frame #582 to #584:

camera running off

Another thing is, when I hit F12 to render the scene on frame #582 with the shuttle still in view, everything is fine until the compositing finished - than the view is covered completely in a light grey color - but I guess that's just the smoke domain completely filled homogenously because I don'T have the simulation data. But I'm not going to analyze this complex setup in the Compositor to find out what's going on there - the main reason your objects disappear is the camera flying off in the distance.

Here just the comparison between what is rendered from the camera and the result after compositing, I have no idea if it's supposed to be like that but as I said before, I guess that's just the smoke domain missing the simulation data:

compositing

$\endgroup$
12
  • $\begingroup$ hah! knew it would be a camera transform / clipping issue! $\endgroup$
    – Lauloque
    Oct 12, 2023 at 15:59
  • 1
    $\begingroup$ @L0Lock Yep, you were right. Well, less a clipping issue since the end was set to 100000' or so and the scene is "only" something like 47000' away, but it is completely off. $\endgroup$ Oct 12, 2023 at 16:36
  • $\begingroup$ Indeed. Though it might not be the case here, if both clipping distances aren't scaled together, it can give issues too. $\endgroup$
    – Lauloque
    Oct 12, 2023 at 17:25
  • $\begingroup$ @GordonBrinkmann The scene is meant to be large, it's a landscape shot. And the camera is meant to move and change view, it's at 582 it sees the smoke sim, but not the shuttle and character models. At 583, when the camera starts to move, smoke sim completely disappears. It didn't used to do this, it just started suddenly, and it comes and goes, sometimes it is in the frames, and like now, it isn't. $\endgroup$ Oct 12, 2023 at 18:35
  • $\begingroup$ Actually it always sounded to me as if you were wondering where your objects have gone. For the smoke simulation: did you bake it? Because the blend file of course does not contain the baked data files, so that is nothing we can check from your file if your simulation data is okay. $\endgroup$ Oct 12, 2023 at 19:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .