1
$\begingroup$

I tested a cycles render in 2.8 and my cpu temps were really high like 90 degrees high.

I then tested a cycles render with my GPU instead of the CPU, although my GPU temps remained low the CPU temps got really hot again.

So if my settings are to render with the GPU why would my CPU be doing any work and still getting hot?

How can I isolate my renders to just the GPU, keep in mind I am setting the render settings to GPU render but my CPU still putting in work evidently.

Which doesn't make sense if i'm using the GPU for renders. NM i was about to add a screenshot and realized when i select GPU it becomes grayed out so evidently a AMD RX580 is not compatible with blender.


Do I need to do some additional setting up somewhere within blender? Also my drivers are all up to date, as for the cooling I need to purchase a after market cooler anyway, right now I'm just using the stock cooler that came with my Ryzen 5 2600 a Wraith Stealth Cooler which does pretty well with everything else except cycles renders. I also have some Artic MX-2 thermal compound I been meaning to apply maybe that will help a little better over the pre-applied compound. But I've seen other posts where people mentioned cycles making CPU temps jump real high [with good coolers] so idk. I've included a pic to show you cycles grey's out when I select GPU render.enter image description here

$\endgroup$
3
  • $\begingroup$ If you CPU gets that hot, you seriously need a proper CPU fan and/or clean the case. This can literally break your hardware. $\endgroup$ – Robert Gützkow Jul 31 '19 at 11:53
  • $\begingroup$ Radeon RX 580 is GCN 4th generation and is supported. Perhaps you need to update your graphics driver (besides fixing the overheating problem). $\endgroup$ – Robert Gützkow Jul 31 '19 at 12:25
  • $\begingroup$ Sounds terribly unrelated to blender and is by NO MEANS MEANT AS ANY FORM OF CRITISM...but may be the fins of the fan cooler of the CPU are stuck in dust...and no heat which is slightly "above normal" can escape anymore This is quiet normal...think of the huge amount of air the fan is pressing through the cooler evert hour. And :) ... a vacuum cleaner does not help here ... you need to blow air over the cooler. And to help the environment please do not used "canned air" ... that is compressed air in spray bottle-ish containers. The "air" is a carbon-hydronium-something and no air at all. $\endgroup$ – user60781 Aug 31 '19 at 17:11
0
$\begingroup$

Turn off the CPU in the GPU render by going into Preferences > System, and under the CUDA Settings, uncheck the CPU.

I noticed this, too. I'll say that, under the same load, with similar effects and raytracing options, Blender renders, CPU, GPU, or shared, run hotter than in other software, for me.

Blender renders hit 90+ degrees after five or so minutes. Cinema 4D doesn't really go beyond 84 degrees.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.