0
$\begingroup$

I got this abstract model from Sketchfab of cool visual effects. These are fully shaded and animated.

enter image description here

However, when I try to import these into Blender, they show up like this:

enter image description here

I would like to be able to play with these visuals and import them into Unity for a project. I tried to "View Render" and "Render Animation" in Blender but still nothing, none of the original materials etc.
There is just the mesh animation which plays (which also breaks when I try to export to FBX then put into Unity, so there's that as well..)

But even if the animations didn't work, and I couldn't put it in Unity, I would at least just like to be able to use the original visuals in Blender.

$\endgroup$
2
  • 1
    $\begingroup$ Some of the stuff you mentioned indicates you need to learn how rendering and shading works. But also, a lot of times, materials for imported models aren’t properly configured automatically, and you have to set them up yourself. I recommend you wait on this import, and learn how to make materials along with about rendering and viewport shading. docs.blender.org/manual $\endgroup$
    – TheLabCat
    Jul 27, 2023 at 20:10
  • $\begingroup$ @TheLabCat Yeah, I'm not very proficient at Blender or 3D modelling, my expertise is in development and the Unity side. However, I've successfully imported many many models with ease and done the editing on their materials and shading, animations, etc as needed afterwards in Unity. That's why I was wondering what in particular is up with these models compared to everything else I've used. $\endgroup$ Jul 31, 2023 at 3:57

1 Answer 1

0
$\begingroup$

The provided blend file seems to be messed up in a few ways, the sphere is opaque, only one material calling for an un-provided texture, and the provided textures don't seem to work.

I recommend you to download the gltf file instead. It seems to work on my side, and it might even be importable by Unity directly without the need to do anything in Blender. I'm not sure the animation will work though.

If animation doesn't show correctly in Unity, we can try baking it in Blended on the mesh objects themselves instead of having the animation on their parent empty objects:

  • Import the gltf in Blender
  • Select everything with A
  • open the operator search with F3, search "Bake Action" and click it
  • Set the end frame to 232 as per your last keyframe, enable "Clear Constraints" and "Clear Parents"
    enter image description here
  • Click Ok and wait for the baking to be done
  • Menu Select > Select All By Type > Empty
    enter image description here
  • Delete the empty objects.
  • A to select all, then hold ⇧ Shift and click the big main sphere once or twice so that it becomes outlined in yellow (while the rest of the selection is orange).
  • ⎈ CtrlP > Set Parent To Object (Keep Inverse)
    enter image description here
  • Then you can export, though I recommend exporting as gltf as it should be able to transmit materials right away.
$\endgroup$
1
  • 1
    $\begingroup$ Thank you so much for the detailed help and instructions! I will try this out. $\endgroup$ Jul 31, 2023 at 3:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .