enter image description hereAs soon as I enable the Subsurface in the Principled BSDF, it's just painting a lot of mostly white, small dots on the mesh, no matter what color I use as subsurface color. I tried changing all the parameters but it didn't help. It works just fine with Eevee for some reason but not with Cycles. The mesh is made out of a nurbs path and modelled to look like hair. Any help is appreciated. Edit: Im using a subsurface radius of 0.5

enter image description here enter image description here

  • $\begingroup$ Hello ! Could you add a screenshot of the problem ? Remember that subsurface values are supposed to be in meters (or blender units) so you should use very low values to get a realistic effect. Make sure your object is to-scale, too. $\endgroup$
    – Gorgious
    Mar 1 at 22:24
  • $\begingroup$ @Gorgious Hi, thanks for your help. I have added two pictures; one with subsurface and the other without. Additionally, I have included a picture of the Principled BSDF. Im using a subsurface radius of 0.5. $\endgroup$
    – Mash
    Mar 2 at 16:34
  • $\begingroup$ What do you mean Im using a subsurface radius of 0.5? You put 0.5 on all three channels? Default is 1:0.2:0.1. Also the SS value is more often around 0.03, definitely never 0.1, that's ten times too much. Why do you use SSS for hair ? $\endgroup$
    – L0Lock
    Mar 2 at 17:18
  • $\begingroup$ @Gorgious Well, I guess I don't really have to use it, but I'm just wondering why it's not working. Changing the values isn't doing anything noticeable. $\endgroup$
    – Mash
    Mar 2 at 22:29
  • $\begingroup$ Well my first comment still stands. A real hair strand is fractions of a millimiter in diameter. here you are setting a subsurface value of 100 millimeters ! You should read a bit on how subsurface scattering works $\endgroup$
    – Gorgious
    Mar 3 at 7:25


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy