I have been unsing Blender for years but am no way an expert. Usually eveything works fine. But today I have the exact same symptoms as in Render turns black when finished, but the proposed solutions do not work.

  • I have a scene that under (Z) -> 8 appears fine.
  • In the outliner the disabled(hidden) objects are exactly the same for the viewport and the render.
  • Renderer engine is Cycles, I render a still picture (not an animation).
  • I have "use nodes" unchecked in "Compositor"
  • I have only one layer, only one scene, which contains only one collection which contains all the objects, camera, and light.
  • If I switch the renderer to Eevee, it renders fine.

I do not have the same symptom as Render result is completely blank who gets a gray area with a grid: I get a pitch black image. None of the 12 fixes of the accepted answer either works or concerns my situation. Color management is sRGB and I restarted Blender and even the computer.

I do not have the same symptom as Why does my object not show up? either. There is a huge list of fixes there, I just cannot try them all.

This question appears a lot on this forum. The most common answer is to enable/disable the nodes in compositor and/or to Properties (choose this in upper left corner of any frame)->Output properties->Post processing-> check/uncheck compositing and/or sequencer and/or add composite and render layers to compositor and link their image slots. I tried many different combinations, none worked.

At 30%: 30%

At 100%: 100%

  • $\begingroup$ Er... It does the same thing with the default cube scene. Does it mean there is a bug in Blender 3.0.1? $\endgroup$
    – Arnaud
    Oct 2, 2022 at 16:06

1 Answer 1


I downloaded Blender 3.3 from the website instead of using the version 3.0.1 installed via apt and it just worked.

By doing this I loose the nice updating features of apt.

  • $\begingroup$ Well, try another method (for example, adding an additional repository): ubuntuhandbook.org/index.php/2021/10/… $\endgroup$
    – quellenform
    Oct 2, 2022 at 18:06
  • 1
    $\begingroup$ @quellenform Indeed the snap version is 3.3. Usually apt installed soft work better. Apparently not this time. $\endgroup$
    – Arnaud
    Oct 2, 2022 at 21:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .